Microsoft Excel 2010
Basics I – Navigating & Formatting
# Microsoft Excel: Basics I - Navigating and Formatting

2.0 hours

This workshop assumes no experience with Microsoft Excel. In this workshop we will learn keyboard and mouse shortcuts to quickly move through the worksheets and to format the text. Topics include an introduction to Excel; working with selections; entering and editing data in cells; cut and copy vs. move and duplicate; resizing, inserting and deleting columns and rows; formatting cell fonts, alignments, numbers, borders and shading. Lots of shortcuts!

<table>
<thead>
<tr>
<th>Sections</th>
<th>Pages</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text Modes</td>
<td>1</td>
</tr>
<tr>
<td>Moving Between Cells</td>
<td>1</td>
</tr>
<tr>
<td>Navigating using the keyboard</td>
<td>1</td>
</tr>
<tr>
<td>- Enter Key</td>
<td>1</td>
</tr>
<tr>
<td>- Tab Key</td>
<td>1</td>
</tr>
<tr>
<td>- Page Up and Page Down Keys</td>
<td>1</td>
</tr>
<tr>
<td>- Arrow Keys</td>
<td>2</td>
</tr>
<tr>
<td>- Home Key</td>
<td>2</td>
</tr>
<tr>
<td>- End Key</td>
<td>2</td>
</tr>
<tr>
<td>- Escape Key</td>
<td>2</td>
</tr>
<tr>
<td>- Delete Key</td>
<td>3</td>
</tr>
<tr>
<td>- Backspace Key</td>
<td>3</td>
</tr>
<tr>
<td>Navigating Using the Mouse</td>
<td>3</td>
</tr>
<tr>
<td>- Single-Click</td>
<td>3</td>
</tr>
<tr>
<td>- Double-Click</td>
<td>3</td>
</tr>
<tr>
<td>Navigating Using the Mouse and Keyboard</td>
<td>3</td>
</tr>
<tr>
<td>- Shift-Click</td>
<td>3</td>
</tr>
<tr>
<td>- Ctrl-Click</td>
<td>3</td>
</tr>
<tr>
<td>The Clipboard</td>
<td>3</td>
</tr>
<tr>
<td>- Clipboard</td>
<td>4</td>
</tr>
<tr>
<td>Shortcut Keys</td>
<td>4</td>
</tr>
<tr>
<td>Cut</td>
<td>4</td>
</tr>
<tr>
<td>Copy</td>
<td>4</td>
</tr>
<tr>
<td>Moving and Duplicating with the Mouse</td>
<td>5</td>
</tr>
<tr>
<td>- Fill Handle</td>
<td>5</td>
</tr>
<tr>
<td>Paste Options</td>
<td>5</td>
</tr>
<tr>
<td>- Paste</td>
<td>6</td>
</tr>
<tr>
<td>- Paste Values</td>
<td>6</td>
</tr>
<tr>
<td>Other Paste Options</td>
<td>6</td>
</tr>
<tr>
<td>Paste Special</td>
<td>6</td>
</tr>
<tr>
<td>Format Painter</td>
<td>8</td>
</tr>
</tbody>
</table>
Microsoft Excel: Basics I - Navigating and Formatting  
2.0 hours

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo and Redo</td>
<td>8</td>
</tr>
<tr>
<td>Undo</td>
<td>8</td>
</tr>
<tr>
<td>Redo</td>
<td>8</td>
</tr>
<tr>
<td>Zoom Slider</td>
<td>9</td>
</tr>
<tr>
<td>Formatting Cells</td>
<td>9</td>
</tr>
<tr>
<td>Font - Ribbon</td>
<td>9</td>
</tr>
<tr>
<td>Font - Format Cells Window</td>
<td>10</td>
</tr>
<tr>
<td>Border - Format Cells Window</td>
<td>11</td>
</tr>
<tr>
<td>Line</td>
<td>11</td>
</tr>
<tr>
<td>Presets</td>
<td>11</td>
</tr>
<tr>
<td>Border</td>
<td>11</td>
</tr>
<tr>
<td>Fill - Format Cells Window</td>
<td>11</td>
</tr>
<tr>
<td>Background Color</td>
<td>12</td>
</tr>
<tr>
<td>Patterns</td>
<td>12</td>
</tr>
<tr>
<td>Alignment - Ribbon</td>
<td>12</td>
</tr>
<tr>
<td>Alignment - Format Cells Window</td>
<td>13</td>
</tr>
<tr>
<td>Text Alignment</td>
<td>13</td>
</tr>
<tr>
<td>Orientation</td>
<td>14</td>
</tr>
<tr>
<td>Text Control</td>
<td>14</td>
</tr>
<tr>
<td>Right to Left</td>
<td>14</td>
</tr>
<tr>
<td>Number - Ribbon</td>
<td>15</td>
</tr>
<tr>
<td>Number - Format Cells Window</td>
<td>15</td>
</tr>
<tr>
<td>Styles Group</td>
<td>16</td>
</tr>
<tr>
<td>Shortcut Keys</td>
<td>17</td>
</tr>
<tr>
<td>Class Exercise</td>
<td>18</td>
</tr>
</tbody>
</table>

Pandora Rose Cowart  
Education/Training Specialist  
UF Health IT Training  
C3-013 Communicore  
PO Box 100152  
Gainesville, FL 32610-0152  
(352) 273-5051  
prcowart@ufl.edu  
http://training.health.ufl.edu

Updated: 5/22/2016
Text Modes

There are three basic text modes in Excel. The current mode can be found on the status bar, at the bottom left corner of the Excel Window.

- Excel is begins in **Ready** mode. This means nothing is being *entered* or *edited* on the spreadsheet. In **Ready** mode, the keyboard arrows, and home/end keys will move you between cells.
- Excel changes to **Enter** mode when you begin to *enter* data into the cell. You can type directly into any current cell, or double click on an empty cell to be in Enter mode. In **Enter** mode, the keyboard arrows, and home/end keys will move you between cells.
- Excel changes to **Edit** mode when you double-click on a cell with data in it, when you click inside the formula bar or when you press the **F2** key on the keyboard (**F2** will also toggle you between **Edit** and **Enter** mode). **Edit** mode allows you to use the keyboard arrows, and home/end keys to move among the characters within the cell.

Moving Between Cells

Navigating using the keyboard

**Enter Key**

The **Enter** (sometimes called the Return) key will move the focus down one cell. If you are in **Edit** or **Enter** mode, Excel will accept changes and move down.

- Using the **Shift** key and the **Enter** key will move the focus up one cell.
- Using the **Ctrl** key and the **Enter** key will accept changes and remain on the current cell. This is the same as clicking the ✓ in front of the formula bar.
  - Inside a selection **Ctrl-Enter** will fill in the contents of the cell being edited into every cell in the selection.
  - Using the **Alt** key and the **Enter** key will put in a hard return; that is, it forces a cell to put text on a second line.

**Tab Key**

The **Tab** key moves the focus one cell to the right. If you are in **Edit** or **Enter** mode, Excel will accept changes and move right.

- Using the **Shift** key and the **Tab** will move the focus one cell left.
- Using the **Ctrl** key and the **Tab** will move you to another Workbook (another Excel file).
- Using the **Alt** key and the **Tab** will move you to another open program on your computer.

**Page Up and Page Down Keys**

The **Page Up** and **Page Down** keys will move the focus of the current cell to the last visible cell on the previous screen, that is, it moves down one "screenful" of cells.

- Using the **Ctrl** key and the **Page Up** or **Page Down** keys will move to the previous or next Worksheet, respectfully.
- Using the **Alt** key and the **Page Up** or **Page Down** keys moves a "screenful" left or right, respectively.
Arrow Keys

In Ready mode and in Enter mode the arrow keys will move in the direction they point: up, down, left and right by one cell, respectively.

- Using the Shift key and the arrows will select a range of cells as you move.
- Using the Ctrl key and the arrows will move the current cell to the edge of the current data region (where the data stops/starts).
  - Using both the Shift-Ctrl and the arrows keys will select all the cells from the current cell to the edge of the current data region.

In Edit mode the arrow keys will move you up, down, left and right between the letters and lines within the cell (if you only have one line of text the up and down arrows have no effect).

- Using the Shift key and the arrows will select text in that direction
- Using the Ctrl key and the left and right arrows will move word by word
  - Shift-Ctrl and the left and right arrows will select text, word by word

Home Key

In Ready and Enter mode the Home key moves to the first column within that row.

- Using the Shift key and the Home key will select from the current cell to the first column within that row.
- Using the Ctrl key and the Home key will move to the very top of your worksheet.
  - Shift-Ctrl-Home will select from the current cell to the very top of the worksheet

In Edit mode the Home key moves to the beginning of the cell.

- Using the Shift key and the Home key will select from where the cursor is blinking to the beginning of the cell.

End Key

In Ready mode the End key turns on an End feature. You will see the "END" appear on the status bar. Once it's on, you can then press an arrow key and it will search in that direction for a change in the cell pattern (with/without data). A similar method can be used by simply using the Ctrl key and the directional arrow.

- Ctrl-End moves to the last working cell on the worksheet, which is the cell at the intersection of the right-most used column and the bottom-most used row (in the lower-right corner)
  - Shift-Ctrl-End will select from the current cell to the last (working) cell on the spreadsheet

In Edit mode the End key moves to the end of the cell.

- Using the Shift key and the End key will select from where the cursor is blinking to the end of the cell.

Escape Key

The Esc (escape) key is the cancel button; if you are editing/entering data in a cell, escape will ignore any changes you have made and return you to the original data or blank cell. This is the same as clicking the x in front of the formula bar. Esc will close dialog boxes such as open, save as.
Delete Key

In Ready mode the Delete key will erase the contents of the cell, not the formatting. To erase the formatting as well, you will need to right-click and choose Delete... or choose Delete from the Home Tab to literally delete the cell from the worksheet. When you do this you will need to tell Excel where to shift the other cells.

In Enter and Edit mode, the Delete key will erase characters to the right of the cursor.

Backspace Key

In Ready mode the Backspace key will erase the contents of the cell and put you into enter mode.

In Enter and Edit mode, Excel will erase characters to the left of the cursor.

- Delete is more universally used throughout windows to remove objects such as images, table cell contents and files. Backspace is used fundamentally for text only.

Navigating Using the Mouse

Single-Click

In Ready mode, clicking on any cell will make it the current cell. In Enter or Edit mode, clicking on a cell will make it the current cell as long as you are not trying to build an equation. If you start a cell with an = or a -, Excel will think you are trying to do math, a Single-Click will change to a Point mode, allowing you to choose cells for use in your equation.

Double-Click

Double clicking on an empty cell will put the cell into Enter mode; double clicking on a cell with data in it will put the cell in Edit mode.

Navigating Using the Mouse and Keyboard

Shift-Click

If you use Shift key and the mouse you can select a range (a set of conjoining cells). Click where you want to start, hold down the Shift key and click where you want to stop. Every cell in between will be selected.

Ctrl-Click

If you use the Ctrl key and the mouse you can select various cells (skipping ones in between). You cannot use these for equations but you can apply formatting (i.e. change several cells to red text).

The Clipboard

Cut, Copy and Paste are clipboard features built into windows. The clipboard is a temporary storage place for pictures and data. The windows clipboard can only store one item at a time. Microsoft Office 2003 and greater has a Multi-Clipboard that can store 24 times, but the Paste button and the shortcuts for the Paste option only correspond to the most recently copied item. The clipboard panel must be displayed to be able to use this feature.
**Clipboard**

Under the Paste button you will see the **Clipboard**. If you click the "more" arrow to the left of the word **Clipboard** it will open the Clipboard Panel.

Once the clipboard is open you will see the pane fill with a new item each time you cut or copy. To retrieve an item from the pane, click on the text/item you wish to paste, and it will appear in the selected cell. If you would like to paste all the cells in the order in which they appear you can click the **Paste All** button. The **Clear All** button will erase all items in the clipboard.

If the clipboard is closed, don’t expect excel to remember more than the last object copied/cut.

To Close the Clipboard click the Clipboard’s "more" arrow, or use the x in the upper right corner of the clipboard pane.

**Shortcut Keys**

<table>
<thead>
<tr>
<th>Ctrl X</th>
<th>Ctrl C</th>
<th>Ctrl V</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cut</td>
<td>Copy</td>
<td>Paste</td>
</tr>
<tr>
<td>X=&gt; Scissors</td>
<td>C=&gt; Copy</td>
<td>V=&gt; Editing Insert character</td>
</tr>
</tbody>
</table>

These characters are also right next to each other on your keyboard.

**Cut**

[Icon: Cutting scissor] The **Cut** feature is used to *move* cells. This button appropriately shows a pair of scissors for the cut option. The short-cut key is **Ctrl-x**.

To use the **Cut** command you need to first select the cell or a set of conjoining cells, and then choose the **Cut** option. When you choose **Cut** a moving marquee (marching ants) will surround the cells, but the data in the cells will still be visible. Click into the cell where you want the upper left most part of your selection to be moved to and press **Enter** or choose **Paste**. Your selection will appear in the designated cell(s), and at the same time disappear from the original location. If your clipboard is not open, you will not be able to **Paste** again.

**Copy**

[Icon: Duplication paper] The **Copy** feature is used to *duplicate* cells. This button appropriately shows two sheets of paper for the copy option. The short-cut key is **Ctrl-C**.

To use the **Copy** command you need to first select the cell or a set of conjoining cells and then choose the **Copy** option. When you choose **Copy** a moving marquee (marching ants) will surround the selected cells.
Click into the cell where you want the upper left most part of your selection to appear and press Enter or choose Paste.

- If you choose Enter the marching ants will disappear from your original selection and you will have a duplicate in the designated spot. If your clipboard is not open, you will not be able to Paste again.
- If you choose one of the Paste options, the duplicate will appear, but the marching ants continue around your original selection, this is so you can continue to make copies by pasting. You will be able to paste as long as the original selection has the moving marquee (marching ants).

Moving and Duplicating with the Mouse

If you put your mouse over the border of the selected cell(s), you will get the Select Arrow.

- Hover over the border and drag (don’t let go of the mouse) and a shadow will follow your mouse. Let go and the select text will be Moved to the new location.
  - Drag means to click the left button on the mouse down, but not let go, and then move the mouse where you want to go, then you can let go of the mouse.
- Use the Ctrl button while dragging the mouse and you will see a small plus sign added to the shadow.
  - When you let go, Word will Duplicate the selection instead of moving it.

Fill Handle

The Fill Handle is in the bottom left corner of the selected cell. When you place your mouse over this handle, it changes from a thick white selection cross, to a thin black cross. Once you see the darker cross you can click and drag the cell to fill the original cell's contents into the newly selected cells. The handle allows the mouse to move in a single direction (up, down, left or right). If you want to go in two directions, you must first complete one way, let go of the mouse and then drag again in the second direction.

When you use the Fill Handle to pull down a single number or plain text, it will copy the data.

<table>
<thead>
<tr>
<th>Text</th>
<th>123</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>123</td>
</tr>
<tr>
<td>Text</td>
<td>123</td>
</tr>
</tbody>
</table>

This is discussed more in depth in the Excel Basics II – Math and Functions workshop handout.

Paste Options

The Paste feature is used to retrieve the most recent item that has been sent to the clipboard through Copy and Cut. This button appropriately shows a sheet of paper coming from a clipboard for the paste option. The shortcut key is Ctrl-V.

Once a set of cells or an object has been copied or cut, then you can use the Paste option to move or duplicate your selection.

The arrow under paste provides a dropdown menu with several paste options.
**Paste**
- **Paste** will paste the copied cell contents and formatting
- **Formulas** will paste the formulas without formatting
- **Formulas and Number Formatting** will paste the copied cell contents and number formatting
- **Keep Source Formatting** will paste the copied cell contents, number formatting, and cell formats
- **No Borders** will paste the cell contents and formatting, but no borders
- **Keep Source Column Widths** will paste the cell contents, formatting and cell width
- **Transpose** will paste a horizontal set of cells into a vertical set of cells, or a vertical set of cells into a horizontal set of cells

**Paste Values**
- **Paste Values** will paste the raw values instead of the formulas
- **Paste values and number formats** will paste the raw values instead of the formulas, but with the number format from the original cells
- **Values and Source Formatting** will paste the raw values instead of the formulas, but with the number format and cell formats from the original cells

**Other Paste Options**
- **Formatting** will paste only the formatting from the original cells, not the contents (Format Painter)
- **Paste Link** will link the new cell to the old such that any changes to the old data will be made here
- **Paste Picture** will create a floating picture based on the copied cells
- **Paste Linked Picture** will create a floating picture based on the copied cells which is linked to the original value so changes made in the original data will be reflected in the picture.

**Paste Special**
The **Paste Special** option can be found on the shortcut (right-click) menu, and the **Paste** dropdown menu (see previous page). If this option is grayed out, it means that nothing is currently on the clipboard.
Paste Options

- **All**: paste cell contents and formatting
- **Formulas**: paste the formulas staying true to the absolute and relative references
- **Values**: paste only the raw numbers
- **Formats**: pastes only cell formatting
- **Comments**: pastes comments attached to the cell, but not the data
- **Validation**: pastes data validation rules for the copied cells to the paste area
- **All using Source theme**: pastes only theme of original cells
- **All except borders**: pastes cell contents and all formatting except the border lines surrounding the original cells
- **Column widths**: pastes the width of a column (or range) to another column (or range)
- **Formulas and number formats**: pastes formulas and all number formatting
- **Values and number formats**: pastes the raw numbers and number formatting
- **All merging conditional formats**: pastes formulas, formatting and conditional formatting

Operation Options

The Paste Special Operation option allows you to specify a mathematical operation that you want to happen between the copied data and where you are pasting the data.

Example: A1:A2 are copied onto B1:B2, using an Add Operation

![Image of matrices showing operation](image)

Other Options

- **Skip blanks** - Avoids replacing values in your paste area when blank cells occur in the copy area.
- **Transpose** - Changes columns of copied data to rows, and rows of copied data into columns.
- **Paste Link** - Links the pasted data to the active worksheet.
**Format Painter**

Paste special has a "Paste Formatting" option and there is a button, (Formatting), on the paste drop down, these options will paste only the formatting from the original cells, not the contents.

Microsoft Office also has a button for this feature; it’s called the **Format Painter**.

The **Format Painter** copies the format of selected cells and applies the format to the cells you specify. This button appropriately shows a paintbrush.

To use the **Format Painter** you need to first select the cells that have the format you wish, click once on the button (a paintbrush will follow your mouse pointer), and then click on the cell(s) you want to reformat.

This tool turns itself off after each use. To turn it on, and keep it on, double click on the button on the Home Tab. To turn it back off, click on the button again or press the escape key (**Esc**).

---

**Undo and Redo**

Microsoft Excel keeps track of almost every task you perform. If you accidentally delete or change something you didn’t mean to, you can usually **Undo** whatever you have just done. Excel allows you to **Undo** multiple times, and even to **Redo** things. The **Redo** allows you to undo the undo.

---

**Undo**

The **Undo** feature is used to go back one step. This button shows an arrow looping counterclockwise. The short-cut key is **Ctrl-Z** and the button can be found above the Home Tab, on the Title bar.

To do multiple Undoes at once you can click the dropdown arrow next to the undo button and see the list of actions you have performed. You cannot go back and undo a task without undoing all the steps that lead up to that point.

---

**Redo**

The **Redo** feature is used to go forward one step. This button shows an arrow looping clockwise. The short-cut key is **Ctrl-Y** (*see note below) and the button can be found above the Home Tab on the Title bar.

To do multiple Redoes you can click the dropdown arrow next to the redo button and see the list of actions you have undone. You cannot go back and undo a task without undoing all the steps that lead up to that point.

* If there is nothing to redo, Excel puts a **Repeat** feature in **Redo**’s place and assigns the short cut key (**Ctrl-Y**) to **Repeat**. For example, if you delete a row, the repeat row will allow you to delete another and another...
**Zoom Slider**

In the bottom left corner of your status bar is a Zoom Slider. The percent can be set between 10% and 400%.

- The plus will zoom in and make the worksheet appear larger; the minus will zoom out and make the worksheet appear smaller.
- You can use the arrow in the middle of the zoom bar, to make adjustments.
- If you click on the actual percentage shown, Excel will open the Zoom window.

---

**Formatting Cells**

The most common formatting options are found on the **Home Tab**. All the options can be found in the Format Cells window. This contains several tabs to help us format the contents of our spreadsheet. This window can be opened by using the **More Options** button at the end of the **Format, Alignment** and **Number** groups. You can also use the Keyboard Shortcut – **Ctrl-1** or choose **Format Cells...** from the right-click shortcut menu.

**Font - Ribbon**

1. **Font** – Sets the font of the selected cell(s). Fonts are different ways to show the same letters.

2. **Font Size** – Sets the size of the letters (the font). Larger numbers give larger fonts. You can type a custom size into this box. Excel will allow you to use the numbers 1 through 409, including half sizes (such as 15.5).

3. **Increase Font** – Increases the font to the next Font Size on the list

4. **Decrease Font** – Decreases the font to the next Font Size on the list

5. **Bold** – Makes the selected cell(s) **Bold**. This button is a toggle, bold/not bold. Shortcut keys are Ctrl-B and Ctrl-2.

6. **Italic** – Makes the selected cell(s) **Italicized**. This button works as a toggle, italicized/not italicized. Shortcut keys are Ctrl-I and Ctrl-3.

7. **Underline** – Makes the selected cell(s) **Underlined**. This button works as a toggle, underlined/not underlined. Shortcut keys are Ctrl-U and Ctrl-4. The drop down arrow lets you choose between single and double underlines.

8. **Borders** – Adds and removes borders for the selected cell(s). The drop down arrow will provide a long menu of border possibilities. To get to the dialog box for more control you can choose **More Borders...** from the bottom of the menu.
9. **Fill Color** – Changes the background color of the selected cell(s). By default the cells have "No Fill"; this is not the same as a White Background. Each time you choose a fill color from this button two things will happen, the background color in the cell(s) you had selected will change, and the default color on the button will change. This is so you can click on the button to use the same color on another cell.

10. **Font Color** – Changes the color of the font of the selected cell(s). Each time you choose a font color from this button two things will happen, the font color in the cell(s) you had selected will change, and the default color on the button will change. This is so you can click on the button to use the same color on another cell.

11. **More Options** – This button will open the Format Cells dialog window to the Font Tab, discussed below.

---

**Font - Format Cells Window**

- **Font** sets the font of the selected cell(s). Fonts are different ways to show the same letters.

- **Font Style** offers four options. Regular, *Italic*, **Bold**, **Bold Italic**.

- **Size** sets the size of the letters (the font). Larger numbers give larger fonts. You can type a custom size into this box. Excel will allow you to use the numbers 1 through 409, including half sizes.

- **Underline** places a line under the data. The drop down arrow lets you choose between single and double underlines.

- **Color** changes the color of the font of the selected cell(s).

- **Normal Font** will reset the selected cells back to their default values. The defaults can be changed under the Office button in the upper left corner -> Excel Options -> Popular.

- **Strikethrough** places a single line through the data in the cell, usually to indicate the data is no longer valid. `Strikethrough`.

- **Superscript** raises and shrinks the selected text, used in text like 3rd and x². (Superman goes up)

- **Subscript** lowers and shrinks the text, used in text such as H₂O and HA₁C. (Subway goes down)
Border - Format Cells Window

By default the gridlines around the cells of your spreadsheet do not print. If you would like them to print, you can turn them on from the Page Layout Tab, click Print under the Gridlines option.

The Font group of the Home Tab has a borders button, 📊. This button has multiple border options, but for more control you can come to this window.

Line

You can choose a line style and a line color that you would like for your border. The line style/color you choose will not be applied until you choose a Preset or a Border option.

Presets

There are three preset border options: None (no borders), Outline (Top, left, right, bottom borders), and Inside (inner borders). These will be created based on the line style and color selected.

Border

The Border group does more than show a preview of the preset options, it allows you to choose to turn on or off any border (top, middle, bottom, diagonal left, left, center, right, diagonal right). Select the line style and color and then click within the preview window, or on the actual border button to see the change. To turn off the border, click on the border or border button again, or choose the none option from the Presets.

Fill - Format Cells Window

By default the cell background has no color. There are many options available to give your data more depth.

The Font group of the Home Tab has a fill button 📊. This button has multiple fill options, but for more control you can open the Format Cells Window.

Remember if you use a dark background color to use a light font color. The font color can be changed on the Font tab of the Format Cells window, or from the Font group of the Home Tab 📊.
**Background Color**

The Background Color shows the same palette of colors we see on the Home Tab. Click on a color to choose it as your new background color.

In Office 2007/2010, we are no longer limited to a small set of colors. If the color palette is not sufficient, you can use the **More Colors** button. This will give you a honeycomb of multiple color options. If you want to go even deeper, you can choose to **Custom** build a color.

The **Fill Effects** button offers you multiple gradient options.

Patterns

A pattern allows us to put lines and hash marks in the background of our cell(s). Along with the pattern that will fill in the background, you have the ability to choose the Pattern Color.

**Alignment - Ribbon**

1. **Top Align** – Vertically aligns the contents to the top of the cell.

2. **Middle Align** – Vertically aligns the contents to the middle of the cell.

3. **Bottom Align** – Vertically aligns the contents to the bottom of the cell. This is the default setting for the vertical alignment.

4. **Orientation** – Rotates the contents of the cell to the currently displayed option. Options include **Counterclockwise** (45°), **Clockwise** (-45°), **Vertical Text**, **Rotate Text Up** (90°), and **Rotate Text Down** (-90°). Choosing the same orientation a second time returns the data to the original state (0° rotation).
5. **Wrap Text** – Displays content on multiple lines within the cell’s column width.

6. **Align Text Left** – Horizontally aligns the contents to the left side of the column.

7. **Center** – Horizontally aligns the contents to the center of the cell.

8. **Align Text Right** – Horizontally aligns the contents to the right side of the cell.

9. **Decrease Indent** – Decreases the space between the text and the cell border for Left, Right and Distributed horizontal alignments.

10. **Increase Indent** – Increases the space between the text and the cell border for Left, Right and Distributed horizontal alignments.

11. **Merge and Center** – Joins selected (adjacent) cells into one cell and centers the result. If there is data in more than one cell, Excel will only keep the information from the upper left cell. The drop down arrow offers a few more options, including Merge Cells and Unmerge Cells. **Merge and Center** will merge the cells from the rows and columns into one large cell. The **Merge Across** option will merge the cells across the columns but not the rows.

12. **More Options** – This button will open the Format Cells dialog window to the Alignment Tab.

---

**Alignment - Format Cells Window**

**Text Alignment**

**Horizontal**: By default Excel has a **General** Horizontal Format, this means that Text is aligned left and numbers are aligned right.

- **Fill** will repeat the contents of the cell as many times as will fit within the width of the column.

- **Justify** keeps the text even on both sides of the cell, as a “full justified” paragraph.

- **Center Across Selection** will center the text in the first cell of across the selection of cells.

- **Distributed** spreads the text out such that text is as evenly distributed as possible. If there is only one word, this option will center the text.

- **Justify distributed** is available when you have chosen a distributed Horizontal alignment. If you choose this option you will not be able to use an indent with the distributed text.
**Vertical:** By default Excel’s Vertical alignment is the bottom of the cell. There are four other options: Top, Center, Justify and Distributed. Top, Center, and Bottom are self-explanatory.

Justified and Distributed vertical alignments will wrap your text so that the contents fit within the column width and will place blank space between the lines as necessary to have the words touching the top and bottom of the cell. If there is only one line of text Justified text will remain at the top of the cell, Distributed in the Middle.

The **Indent:** option only available with the alignments that offer (Indent) in the list. The number represents the number of characters you wish to indent by.

**Orientation**

These tools allow you rotate your text within 180 degrees, from left side to right side, as well as arranging each letter into a single column.

When you change the orientation you the borders will follow the slant of the text.

For the least amount of distortion, try to stay with the 90°, 45°, 0°, -45° and -90° values.

**Text Control**

The text controls are toggle options. If the box is checked the option is on, if the box is blank the option is off. If a light gray check appears in the box, then some cells have the option and some do not; click once to turn on the option for all selected cells, and again to turn off for all selected cells.

- **Wrap Text** will keep text inside its own cell by creating multiple lines.
- **Shrink to fit** will reduce the size of the text such that it appears smaller when the column is not wide enough to show its true size.
- **Merge Cells** will join the selected (adjacent) cells into one cell. If there is data in more than one cell, Excel will only keep the information from the upper left cell.

**Right to Left**

This option specifies the reading order and alignment for different languages. Text is usually entered to the left of the cursor, in some languages it is expected to go to the right of the cursor. This setting will adjust the flow of data, if your computer is set to the correct language.
**Number - Ribbon**

1. **Number Format** – Allows you to change the way numeric values are displayed on the spreadsheet. The drop down arrow gives you a list of the most common formats, including a More Number Formats option.

2. **Currency Style** – Sets the selected cell(s) to the Currency Style, this style keeps the dollar signs on the left side of the cell, and the number on the right side. The drop down arrow gives you a list of other currency formats, such as the Euro (€). This button can be reset through Cell Styles on the Home Tab.

3. **Percent Style** – Sets the selected cell(s) to the Percent Style, this style has zero decimal places. Keyboard shortcut - Ctrl-Shift-%. This button can be reset through Cell Styles on the Home Tab.

4. **Comma Style** – Sets the selected cell(s) to the Comma Style, this style has a comma for every thousand and two decimal places. This button can be reset through Cell Styles on the Home Tab.

5. **Cell Styles** on the Home Tab.

6. **Increase Decimal** – Increases the number of decimal places showing to the right of the decimal.

7. **Decrease Decimal** – Decreases the number of decimal places showing to the right of the decimal.

8. **More Options** – This button will open the Format Cells dialog window to the Number Tab.

**Number - Format Cells Window**

There are 12 categories on the number tab. Each category except General and Text have options for you to choose.

For example, with a Number category you decide how many decimal places, if there should be a comma separation at every 1000, and how to display the negative values.

Dates and Times are numbers, if a date loses its format, Excel will display the numerical representation of the value. You can change it back to a date/time format from the General drop down on the ribbon, or from the Date or Time category here in the Format Cells window.

There are a few Special formats built into Microsoft Excel, these include Zip Codes, Phone Numbers and Social Security Numbers. The idea is, the format will fill in the characters. You can type in 3525551234, and if the cell has a Special "Phone Number" format the cell will display (352) 555-1234.
It is possible to create Custom Formats. Of the options showing here: For example, if you wanted to create a column of UFIDs, you may choose to create a custom format of 0000-0000. This would ensure that all 8 characters are required, and there is a hyphen in the middle. If we type in 123, we will see 0000-0123.

<table>
<thead>
<tr>
<th>Sample</th>
<th>1234-5678</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type:</td>
<td>0000-0000</td>
</tr>
<tr>
<td>General</td>
<td>0</td>
</tr>
<tr>
<td>0.00</td>
<td>#, #;0.00</td>
</tr>
<tr>
<td>#, #;0.00</td>
<td>[Red] (#, #;0.00)</td>
</tr>
<tr>
<td>#, #;0.00</td>
<td>[Red] (#, #;0.00)</td>
</tr>
<tr>
<td>#, #;0.00</td>
<td>[Red] (#, #;0.00)</td>
</tr>
<tr>
<td>[red] – change color of text red</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Sample</th>
<th>12/15/2010</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type:</td>
<td>m/d/yyyy</td>
</tr>
<tr>
<td>1/5/11</td>
<td>d-mmmyy</td>
</tr>
<tr>
<td>1/5</td>
<td>d-mm</td>
</tr>
<tr>
<td>1/5</td>
<td>mm-yy</td>
</tr>
<tr>
<td>1:00</td>
<td>h:mm AM/PM</td>
</tr>
<tr>
<td>1:00</td>
<td>h:mm:ss</td>
</tr>
<tr>
<td>1:00</td>
<td>h:mm:ss:0</td>
</tr>
</tbody>
</table>

### Styles Group

1. **Conditional Format** – Allows you to set Excel to highlight or otherwise bring to attention cells that match criteria. For example, all cells less than $100 turn red, or if the cell contains “Sally” turn the background of the cell green. Select the range before using this tool.

2. **Format as Table** – Allows you to use a preset format for a range of cells. You do not need to select the range if your data is conjoining (all together). Excel will ask if this is the correct set and if your data has headers (titles).

3. **Cell Styles** – Allows you to use a preset style for the format of your cell. Using the styles helps to create a consistent look within you spreadsheet. Excel has many preset styles, but you can create your own. This is where you can reset the Comma, Currency and Percent styles represented by the $, %, buttons in the Number Group.
**Shortcut Keys**

There are many ways to complete tasks in Excel: using the menus; using the toolbars; using the shortcut (right-click) menu; and using the keyboard shortcuts. Here is a list of some of the keyboard shortcuts available in Excel.

<table>
<thead>
<tr>
<th>Key Combination</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl-A</td>
<td>Select All</td>
</tr>
<tr>
<td>Ctrl-B</td>
<td>Bold</td>
</tr>
<tr>
<td>Ctrl-C</td>
<td>Copy</td>
</tr>
<tr>
<td>Ctrl-D</td>
<td>Fill Down</td>
</tr>
<tr>
<td>Ctrl-F</td>
<td>Find</td>
</tr>
<tr>
<td>Ctrl-G</td>
<td>Goto</td>
</tr>
<tr>
<td>Ctrl-H</td>
<td>Replace</td>
</tr>
<tr>
<td>Ctrl-I</td>
<td>Italicize</td>
</tr>
<tr>
<td>Ctrl-K</td>
<td>Hyperlink</td>
</tr>
<tr>
<td>Ctrl-L</td>
<td>Create a List/Table</td>
</tr>
<tr>
<td>Ctrl-N</td>
<td>New Workbook</td>
</tr>
<tr>
<td>Ctrl-O</td>
<td>Open Workbook</td>
</tr>
<tr>
<td>Ctrl-P</td>
<td>Print</td>
</tr>
<tr>
<td>Ctrl-R</td>
<td>Fill Right</td>
</tr>
<tr>
<td>Ctrl-S</td>
<td>Save</td>
</tr>
<tr>
<td>Ctrl-T</td>
<td>Create a List/Table</td>
</tr>
<tr>
<td>Ctrl-U</td>
<td>Underline</td>
</tr>
<tr>
<td>Ctrl-V</td>
<td>Paste</td>
</tr>
<tr>
<td>Ctrl-W</td>
<td>Close Workbook</td>
</tr>
<tr>
<td>Ctrl-X</td>
<td>Cut</td>
</tr>
<tr>
<td>Ctrl-Y</td>
<td>Redo</td>
</tr>
<tr>
<td>Ctrl-Z</td>
<td>Undo</td>
</tr>
<tr>
<td>Ctrl-1</td>
<td>Format Cells</td>
</tr>
<tr>
<td>Ctrl-2</td>
<td>Bold</td>
</tr>
<tr>
<td>Ctrl-3</td>
<td>Italicize</td>
</tr>
<tr>
<td>Ctrl-4</td>
<td>Underline</td>
</tr>
<tr>
<td>F1</td>
<td>Help</td>
</tr>
<tr>
<td>F2</td>
<td>Edit/Enter Mode</td>
</tr>
<tr>
<td>Shift-F2</td>
<td>New Comment</td>
</tr>
<tr>
<td>Shift-F3</td>
<td>Insert Comment</td>
</tr>
<tr>
<td>Ctrl-F3</td>
<td>Name Manager</td>
</tr>
<tr>
<td>F5</td>
<td>Goto</td>
</tr>
<tr>
<td>F7</td>
<td>Spell Check</td>
</tr>
<tr>
<td>Ctrl-F4</td>
<td>Close Workbook</td>
</tr>
<tr>
<td>Alt-F4</td>
<td>Exit Excel</td>
</tr>
<tr>
<td>Alt-Tab</td>
<td>Switch between Programs</td>
</tr>
<tr>
<td>Ctrl-Tab</td>
<td>Switch between Excel Workbooks</td>
</tr>
<tr>
<td>Alt-F</td>
<td>Opens File Menu</td>
</tr>
<tr>
<td>Alt-H</td>
<td>Home Tab</td>
</tr>
<tr>
<td>Alt-N</td>
<td>Insert Tab</td>
</tr>
<tr>
<td>Alt-P</td>
<td>Page Layout Tab</td>
</tr>
<tr>
<td>Alt-M</td>
<td>Formula Tab</td>
</tr>
<tr>
<td>Alt-A</td>
<td>Data Tab</td>
</tr>
<tr>
<td>Alt-R</td>
<td>Review Tab</td>
</tr>
<tr>
<td>Alt-W</td>
<td>View Tab</td>
</tr>
<tr>
<td>Alt-X</td>
<td>Add-Ins Tab</td>
</tr>
<tr>
<td>Alt-F8</td>
<td>Macros</td>
</tr>
<tr>
<td>Ctrl `</td>
<td>Formula View</td>
</tr>
<tr>
<td>Ctrl-Shift-F</td>
<td>Format Cells Window</td>
</tr>
<tr>
<td>Ctrl-Alt-Tab</td>
<td>Increase Indent</td>
</tr>
<tr>
<td>Ctrl-Alt-Shift Tab</td>
<td>Decrease Indent</td>
</tr>
<tr>
<td>Ctrl-Shift-%</td>
<td>Percentage style</td>
</tr>
</tbody>
</table>
Class Exercise

- Introduce parts of Excel
  - Tool bars
  - Name box and formula bar
  - Columns, Rows, and Cells
    - Columns of a building, rows of chairs
  - Worksheet navigation buttons
  - Worksheet Tabs
  - Status bar
    - Excel behaves differently depending on what “mode” you are in

- Move around excel
  - Ctrl- →
    - Column XFD (16,384 - 2^{14}) columns – SET AMOUNT
  - Ctrl- ↓
    - 1,048,576 rows (2^{20} – SET AMOUNT)
  - Ctrl-Home

- Show Excel’s Working area
  - Type the letter A in cell G12
  - From the View Tab choose PAGE BREAK PREVIEW
    - Click OK on the message
    - Notice most of the area is grayed out, but you can still click in the cells
  - Click way down in the bottom right and type the letter B, press enter
    - The print area will snap to that cell. Every page in between A1 and that last cell will be printed.
  - Move up one cell and press DELETE (not backspace)
    - The print area should snap back into place
  - Return to NORMAL view
  - Ctrl Home
  - Delete data in G12

- Change Zoom
  - Change Zoom to 200%, click on ZOOM button
  - Change Zoom Manually to 150%
  - Change Zoom to 0%
  - Play with + & - buttons
  - Change Zoom back to 200%
  - Ctrl-Home

- Moving around
  - Use keyboard arrows to move up, down, left and right
  - Use enter and tab to move down and over
  - Use Shift-Enter and Shift-Tab to move up and back
- Difference between Tab/Enter and Arrows
  - Make a selection of cells (about three by three)
  - Use the enter key to move between the cells
  - Use the tab key
  - Use an arrow key
    - See... Different...

- Selecting Multiple Cells
  - Drag mouse from middle of a cell diagonally across to another cell
  - Use Keyboard
    - Click in a cell, hold down the shift key and at the same time use the arrow keys

- Entering Text (Enter Mode)
  - B2: big city store (all lower case letters)
    - Notice as soon as you type the ‘b’ you change from READY to ENTER

- Editing Text (Edit Mode)
  - Double-click to “get inside” the cell
  - Change first letter of each word to uppercase
  - B2: Big City Store

- Entering Text in Consecutive Cells
  - C2: Sale

- Adjust Column Widths
  - Big City Store gets cut off, so we need to adjust the column
    - Drag the line in the gray area between column headings B and C to make the column wider
    - Drag the line to make the column skinnier, so you can only see Big City
    - Double-click on the line to Auto Fit
    - AutoFit Column C as well

- Copy and Paste
  - Copy Cell B2, notice the moving marquee (marching ants)
  - Paste into another cell, paste into another cell (paste a few...)
  - Read the status bar, press enter to do a ‘final paste’

- Cut and Paste
  - Cut Cell C2, notice the cell does not delete, but we have a moving marquee
  - Paste into an empty cell
    - Notice the original NOW disappears
  - Cut and Paste “Sale” back into C2

- Fill Handle
  - Take Fill handle from bottom left of cell C2 and drag it down two cells
    - Creates two more ‘Sale’ cells
  - Fill handle will be discussed at length in the next class
- Moving Cells
  o Mouse over the edge of the cell until you get the white arrow, click and drag to a blank cell
  o Move again

- Duplicating Cells
  o Pick up a cell as if to move it and hold down the CTRL key at the same time, move to an empty cell. Let go of the mouse BEFORE they keyboard

- Copy/Cut & Paste or Move/Duplicate Cells
  o Delete all extras

- Insert Columns
  o Right-click on Column B, choose Insert
  o Do it again so data lives in D & E

- Formatting Fonts with HOME tab
  o Format Font (D2)
  o Format Size (D3)
    ▪ Custom Sizing (size 15, size 0 for error message)
    ▪ Use Increase and Decrease buttons
  o Format Bold (D4), Italics (D5) and Underline, Double Underline (D6)
  o Format Color (D7)
    ▪ View MORE COLORS
  o Edit Cell D8
    ▪ Double-click to “Get Inside” the cell
    ▪ Double-click each word to format
    ▪ Bold: Big, Italicize: City, Underline: Store
    ▪ Make each word a Different Color

- Format Fonts with Format Cells window
  o Format Cell E2 using “More” Button
    ▪ Comic Sans, Bold, 14, Double Underline, Green

- Use Format Painter
  o In cell E2, click on the format painter
    ▪ Moving marquee means we are copying
    ▪ Click on cell D2, all changes happen at once

  o Try painter again, it turns off
    ▪ Double-click to Keep on

  o Change all cells to this font
    ▪ Cell D8 won't format, Delete

- Format Column/Row
  o Click on Column Letter E to select whole column
    ▪ Change color to Red
  o Click on Row Number 4 to select whole row
    ▪ Change color to Blue
- Format All
  - Click on blank gray square between Column A and Row 1 to select the whole spreadsheet
    - Format Cells Window->Font Tab->Normal Font

- Turn to Sheet 2, Zoom to 200%

<table>
<thead>
<tr>
<th></th>
<th>B</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>Text</td>
</tr>
<tr>
<td>3</td>
<td>123</td>
</tr>
<tr>
<td>4</td>
<td>*</td>
</tr>
<tr>
<td>5</td>
<td>1-Feb</td>
</tr>
</tbody>
</table>

- Starting in B2 type:
  - B2 - Text
  - B3 - *
  - B4 - 123
  - B5 - 2/1
  - Notice the data is on different sides of the cell
    - (text, number, text and date)
      - Text on the left
      - Numbers & Dates on the right

- Alignments with Toolbar
  - (default) General: Text left aligned, number right aligned
  - Select Column, Align Left, Align General (aka NOT left), Align Right, Align Center, Align General

- Indent
  - Bold and Underline B2: Text
  - Select B3:B5
    - Increase Indent
    - Decrease Indent
    - Center Text, Increase Indent, pops back to the left
    - Decrease Indent
    - Right Align Text, Increase indent

- Alignments with Menu
  - Make sure column B is selected
  - Open the more alignments (format cells) window
  - Change the Horizontal to Fill and press ok
    - Type a letter in cell B6, see it repeat
      - ********
    - Careful of ones like =- or -=, excel will think you want an equation and will give you an error message. If you want this pattern you will need a single quote in front

- Delete Column
  - Column selected, press delete on keyboard
  - Type A in cell B2 and Press enter
    - Cell should repeat AAAAAAAA
  - Right-click on column B and Choose DELETE
    - Column will be physically removed, along with its formats
- Copy from another worksheet
  o Turn to Sheet 1
    ▪ Select two of the normal Big City Stores
    ▪ Copy
  o Turn to Sheet 2
    ▪ Paste into Cell B2 on Sheet 2
  o DO NOT ADJUST COLUMN WIDTHS

- Center Across Selection Alignments
  o Select B2:F2, Format Cells, Center Across Selection
  o Select B3:F3, Merge and Center
    ▪ See Merge and Center button

- Copy 2 Big City Stores from Sheet 1
  o Paste into Cell B6 on Sheet 2

- Format B6: Shrink to Fit
  o Adjust Column Widths wider, narrower

- Format B6: Wrap Text (turn off shrink to fit)
  o Adjust Column Widths so line goes through the Y in CITY
    ▪ See Wrap Text button

- Edit B7: Force Enters with Alt Enter

- Merge Block & rotate
  o Select C6 & D7
    ▪ Merge and Center
  o Type in Sale
    ▪ Top/Middle/Bottom
  o Use Orientation button to slant text
  o Open Format Cells Window to view all ORIENTATION options

- Sheet 3: 200%

- Format Numbers
  o In cell B2 type:
    ▪ 1.928374650 and press enter
    ▪ This is not the number that shows
    ▪ Move back to that cell and see the true number in the status bar
  o Use the Increase Decimal button to show the original number
  o Use the Decrease Decimal button to bring it down to 2
    ▪ Notice the formula bar still shows the true contents
  o Click on the Dollar sign button
  o Click on the Percentage button
    ▪ Increase decimal two times
- Click on the Comma style button
  - Edit cell, remove decimal place, Accept
  - Decrease Decimal two times
- Format Cells Window -> Number->General
- Format Cells Window -> Number
  - Peruse different settings
  - Special -> SSN

- Insert Worksheet with new sheet button

- Turn to Sheet 4, Zoom 200%

- Select B2:D4
  - Enter numbers 1-9 (don’t use the mouse)
  - While selected Center

- Format Background Colors
  - Choose White
    - No gridlines
  - Select cells and Choose No Fill

- Format Borders
  - Use Ribbon button
  - More Borders
    - Format Cells Window -> Borders
    - Pick a line, pick a color, pick a location
      - Outside, Inside
      - Top, Middle Bottom
      - Left, Center, Right
      - Diagonal Up, Diagonal Down

- Format Fill
  - Ctrl- 1, or right-click Format Cells
  - Fill Patterns
  - Fill Effects

- Close, Don’t save