Adobe Photoshop CS5
Layers and Masks
Adobe Photoshop CS5: Layers and Masks  
2.0 Hours

The workshop will cover creating and manipulating basic graphics in Photoshop, and sorting and tagging in Bridge. Topics include an overview of common toolbar features, creating images using layers, and adding text to images. This workshop assumes no experience with Photoshop or Bridge, but requires a working knowledge of the Microsoft Windows operating system.

Worksheets:

Layers and Masks ............................................................................................................................ 1
Layers .................................................................................................................................................. 1
Masks .................................................................................................................................................. 2
Why use Layers and Masks ............................................................................................................... 2
The Layer Palette ............................................................................................................................... 3
Managing Layers ............................................................................................................................... 4

Working with Layers and Masks ...................................................................................................... 5
Exercise 1 - Selections and Creating Layers ..................................................................................... 5
Exercise 2 – Layers and Quick Mask Mode ...................................................................................... 6
Exercise 3 - Mask............................................................................................................................... 8
Exercise 4 – Clipping Path .................................................................................................................. 8
Exercise 5 – Grayscale with one color .............................................................................................. 9

Scott Young  
Training Specialist  
Academic Health Center Training  
C3-012A Communicore  
PO Box 100152  
Gainesville, FL 32610-0152  
(352) 273-5051  
scott.young@ufl.edu  
http://training.health.ufl.edu

Updated: 4/16/2012
Layers and Masks

Layers

One of the most important and powerful aspects of Photoshop is the element of layers. Layers in Photoshop are like transparent papers or sheets of acetate.

Layers can hold pixels of colors or they can hold areas of transparency or they can hold information that affects the color or tone of the pixels in the layers below it. If a file is imported or opened in Photoshop it will start with one layer. That first layer of a Photoshop file is the Background layer. The layer is named *Background* in italics.

Once other layers are added to a file, they can be manipulated and moved in the stack of layers. However, the Background layer is locked and cannot be moved or deleted. Also, while new layers in a file can be transparent or have transparent areas, the Background layer cannot have transparent areas.

The best practice is to immediately create a duplicate layer that can be manipulated and leave the Background layer undisturbed. If you do want to use the background layer or move it, it has to be renamed and it will be unlocked and behave as any other layer. To rename a layer, double-click on the name in the Layers Palette and type in a new name. It is always good to name your layers a unique and descriptive name for easy recognition and organization.

Other types of layers are:

- **Transparent layers**, which hold pixels and may also have areas of transparency. The areas of transparency allow pixels on layers below it to show through.

- **Adjustment layers** do not have actually pixel information on them, but data that explains how the pixels on the layer below should have their color or tone changed. These layers can alter the hue, saturation or brightness of the pixels.

- **Text layers** can be applied to an image. Each area of text will create its own layer. Then the text can be altered. The colors or fonts can be changed, the shape or spacing of the characters can be changed, the words can be edited, and many other stylized features such as shadows can be added.

- **Shape layers and Fill Layers** are two other non-pixel layers. These layers do not contain pixels, but the instructions as to what color and what shapes should show.
**Masks**

There are two types of Masks. There are pixel-based masks, which hide or reveal pixels in layers below and there are vector-based masks that hold instructions on how the pixels should be displayed. Masks provide protection from editing, or isolation of parts of your image. Masks are similar to the masking tape you use to protect when painting. With Masks you can make changes of color or effect parts of an image while leaving other parts intact. Masks can be used to make selections of parts of an image. While selections are temporary, a selection can be used to create a mask, which can be saved so it can be reused at another time.

Photoshop saves masks as an alpha channel. Photoshop divides images into individual color channels. An image in RGB mode would have a Red, Green and Blue channel. An alpha channel is actually a grayscale image. Channels can be named just like layers. Masks can be edited using paint tools. Painting will change the opacity of the mask. Black paint in a mask will block out pixels, while the lighter gray will allow more visibility. White allows total visibility.

A quick mask can be used to create selections. The quick mask button in the toolbox makes it very easy to jump back and forth between a selection and a quick mask.

**Why use Layers and Masks?**

- Not only do layers and masks allow you to isolate and make changes to images or parts of images, layers can work together to create many effects.
- Composite images can be created that are more than just pieces of many images pasted together.
- Layers don’t just show or hide the layers below, but can interact with other layers.
- Layers can be blended together to create different effects.
- Adjustment layers can be used to eliminate flaws.
- Layers can be used to correct exposure problems.
- Changes in opacity can allow a soft edge on images.
- Images can be placed inside other images creating interesting new images.
- Text can be manipulated to give depth and interesting appeal.
The Layer Palette

- **Blend Mode** is how that layer reacts with and/or affects the layer below. The most common mode is Normal. The others create many different effects.

- **Opacity** sets how much the layer below is hidden or revealed. 100% opacity is fully opaque, while 1% opacity is almost transparent.

- **Fill Level** is similar to Opacity, but only affects the pixels in the layer and not any layer style that has been applied to the layer.

- **Layer Lock Options** allow you to lock a layer to protect it. By default the Background layer is fully locked and shows a little lock icon. The partial lock options are:
  - **Lock Transparency** – No changes will affect transparent areas
  - **Lock Image** (paintbrush icon) – No changes can affect the pixels on the layer
  - **Lock Position** (four headed arrow) – Pixels cannot be moved on the layer

- You can only affect the Active (selected) layer. A layer shows Active by the dark blue Highlighting and the paint brush icon

Bottom Toolbar
- A. Link Layers
- B. Layer Style
- C. Add Layer Mask
- D. Add a Fill or Adjustment Layer
- E. Add a New Layer Set
- F. Add a New Layer
- G. Delete Layer
**Managing Layers**

Layers can be created, duplicated, rearranged, linked merged and deleted. There are many ways to accomplish these tasks. Below are a few methods.

To **Create a layer**, Choose Layer > New > Layer from the Layer Menu or from the Layer Palette Options choose New Layer or click on the new layer icon on the Layer Palette. When you create a new layer it will appear above the active layer.

To **Duplicate a layer**, Choose Duplicate from either the Layer menu or from the Layer Palette Options. Or drag the layer thumbnail to the New Layer Icon.

To **Rearrange layers** click and drag them into place. You may want to rearrange layers to reveal or hide other parts of lower layers. You may want parts of the image to appear as if it is behind another part of the image.

To **Link layers**, make one layer Active and Ctrl + click to select a second layer. Click on the chain icon at the bottom of the layer palette. A chain icon will appear showing the layers are linked. The linked layers can now be manipulated together.

To **Merge layers**, from the Layer Menu or the Layer Palette Options choose the appropriate Merge option. If you have two layers to merge make the top one active and choose Merge Down. If you have linked layers you choose Merge Linked. If you have several layers to merge, but not all, you make only the layers you want to merge visible. Then you choose Merge Visible. Merging files can help to make the file size smaller. Do not merge layers until you have finished editing the layers. For example if you are working with text and applying layer styles to several layers of text, once you are finished with the text part of your image you might want to merge the text files.

If a layer is no longer needed or did not work out the way it should have, it can be **deleted**. Choose Layer > Delete > Layer from the Layer Menu. Or right-click on the name of the layer and choose delete and say yes to confirm. Or click and drag the layer to the delete icon (garbage can) in the Layer Palette.

Any vector files (shapes and text) must be **rasterized** before some effects can be applied. What that means is that the file or layer must be turned into a bitmap image (grid of pixels) rather than a vector image which is made up of lines and curves. The Photoshop program will ask you if you want to rasterize the layer or you can rasterize it manually by choosing Rasterize from the Layer menu.

Once you have totally finished your image, it can be **Flattened** to reduce file size. The best practice is to save the file as a Photoshop file (.psd) with all the layers intact. Then save a new file as a flattened image. Make sure all the layers to be kept are visible as flattening will discard all hidden layers. Flattening an image will also fill all transparent areas with white.

Layers can be grouped into a Layer Group. It is like putting files into a folder. Layer sets help to keep your layers organized. To create a Layer set, click on the Create a New Group button on the bottom of the Layer Palette (looks like a folder icon). Then you can click and drag your layers into the set. Sets can be color coded for more visibility. Groups allow you to move several layers at a time. Masks applied to the group affect all the layers in the Group.
**Working with Layers and Masks**

**Exercise 1 - Selections and Creating Layers**

1. Open peppers.psd image.

2. Create a duplicate layer by going to **Layer menu > Duplicate**. Name the layer peppers.

3. Select the background of the image with the magic wand tool. Click on the magic wand tool. Look at the option bar. Set the tolerance to 32. Check contiguous. Make sure the Peppers layer is selected. Click on the background. If it doesn't include all of the background, hold down the shift key and click again. The shift key makes the wand add to the selection. There is also an **Add to Selection** button on the option bar.

4. Now we are going to select the peppers by inverting our selection. Go to: **Select > Inverse**. Because the peppers are all different colors and shapes this is the easiest way to select them.

5. Create a new layer containing the peppers and tomatoes. Go to **Layer menu > New > Layer** via cut (we want to take the peppers out of the picture) or right-click in the selection and choose layer via cut Rename the layer by double-clicking on the layer name in the layer palette. Name it Veggies.

6. Turn off and on the visibility of the layers by clicking on the eye icon Leave the background layer off.

7. Select the Peppers layer (the selected or active layer is highlighted blue and shows a paintbrush icon). We will add a gradient to the background. Choose the gradient tool. It may be behind the paint bucket. Look at the options bar. You can open the gradient picker by clicking on the small black triangle. There are several preset gradients or if you click on the color area the gradient editor will open and you can create your own gradient. Just pick one for now by double-clicking on one of the choices. Place your cursor on the left side of the image (making sure you are on the right layer). Click and drag a line across the image. When you let go of the mouse, you should have a new background.

8. Now choose the Veggies layer. Let’s play with filters with this layer. Go to **Filter and look at all the choices. Try the colored pencil by going to Filter>Artistic> Colored Pencil. Click OK to apply. Undo that by going to the **Edit menu bar and choosing **Undo. Try the liquefy command. . Undo that by pressing CTRL + Z. Then try one more and undo that by going to the history palette and click and dragging the tile that says the name of the filter to the trash can at the bottom of the History palette.

9. To save this file we would always want to save it as a .psd file to preserve any layers we have created. Then to save it for the web we would also want to “flatten” all the layers to make the file smaller and then go to save for web and choose the best image. Go to the **Layer menu > Flatten Image**.
Exercise 2 – Layers and Quick Mask Mode

In this first exercise we will start with one image, load a saved selection, create a new layer via copy from the selection, make a new selection using quick mask, save the selection as a channel, make a new layer from the second selection, move the image on the third layer, rearrange the layers, merge layers, give the merged layer a style and finally flatten the image.

1. Open the priests.psd file. You can see it only has one layer, the Background layer. Make a duplicate layer by clicking on the layer name and dragging it to the new layer icon. Rename the layer by double-clicking on the name and type priests. Using the visibility toggle, turn off the background layer.

2. Look at the channels palette. The image is broken up into Red, Green, Blue channels and then there is also an alpha channel. The alpha channel is a grayscale image which is really a mask. The alpha channel was created by saving a selection. You can see the selected area is white while the rest of the image is covered in black. Go to the Select menu and choose load selection.

3. The load selection dialog box pops up and gives the opportunity to load from a choice of selections if more than one is available. It also gives the opportunity to invert the selection if you choose. Choose the channel named outline. Make a new layer by going to the Layer menu and choosing New > Layer > Via Cut. Turn the visibility toggles off and on to see what each layer looks like now. Remember the shortcut to deselect is CTRL + D.

4. Make a selection of the priest in green. Use the magnetic lasso tool and make a fairly quick selection. Click on the Quick Mask Mode button in the toolbox. You will see the part of the image that is not to be selected is covered in a red color, or mask. Make sure your color chips are in the default mode with black being the foreground color. Then switch the background and foreground colors and paint with white the part of the priest that was not selected but should be part of the selection. You can flip back and forth with normal selection view and quick mask view to see how your selection is going. Once you have uncovered the entire priest in green, if you have areas that are included in the selection but should not be switch your colors back and paint with black to cover up those unwanted areas. ** Always switch out of quick mask mode and back into regular mode when you are finished editing your selection**
5. Once the selection of the priest in green is the way you want it, go to the **Select** menu and choose save selection. Give your selection the name one Priest. This is for practice only. Save selections when you think you might need to reuse them, but don’t overdo as it increases file size. Now make a new layer with the one priest by choosing Layer Via Copy.

6. Next we want to place the new priest in green in line behind the one already there. Using the move tool, move the priest into place. However, it doesn’t look good with that layer on top of the two priest layer, so click and drag the one Priest layer down below the priests layer in the layer palette. Use the move tool to position the image if necessary.

7. Once the three priests are in position, we will merge the two layers. Make the top layer active, go to Palettes options and choose Merge Down. Now instead of two layers there is only one. The three priests can now be moved as a single item.

8. We can apply a layer style to the three priests. From the **Layer** menu choose **Layer Style**. We will apply an outer glow to the priests. Choose outer glow. When working with Layer Styles, if you put a check mark in the box for the style Photoshop will apply the style with defaults. If you want to change the style options, select the style and the area in the middle of the Layer Style dialog box will present the options for that particular style. If the preview box is checked you will see how your options will affect your image. If necessary, set blend mode to normal.

9. Once your layer style looks the way you want we will flatten the image. Notice the file size before flattening. Go to Layer Palette Options and choose Flatten image. You will probably get a discard hidden layer warning, say ok. Now check file size and see if it has changed.
Exercise 3 - Mask
This is a simple exercise to combine two images and edit out the background of one without actually cutting anything out of the image. This process will use a layer mask to accomplish this task. This exercise uses a simple image, but the procedure is essentially the same for any type of image.

1. Open the guru_background.bmp file.
2. Open the guru_ball.bmp
3. Use the Move tool to move the ball image into the background image.
4. Use the Elliptical Selection tool to select the ball. Remember that if you hold the shift key down while selecting it will select a perfect circle. If you hold ALT + Shift while you select the selection will start from the center creating a perfect circle.
5. Click on the Add a layer mask icon on the layers palette.
6. Your image should be done. Look at the layers palette and check out the mask. Right-click on the mask thumbnail and check out the options. One option is to load the mask as a selection if you had created the mask first or if you used the mask and want to reuse that selection. The mask is made up of a white area and a black area. The white area is where the ball is so it shows (is revealed). The black area covers the rest of the image so it is hidden. If you were to use a gradient fill or paint with gray various levels of opacity would show through. Another thing to notice is the chain link between the image and the mask. That shows the mask is locked to the image and if one is moved they move together. If you need to move them separately you would click on the link and they would be unlock and have the ability to move separately.

Exercise 4 – Clipping Path
This exercise will create a clipping path. A clipping path is where a base layer masks the layer above.
1. Open the file yellowstone.jpg. Create a duplicate layer and name it lake.
2. Open the file fall.jpg. Using the move tool, move it into the Yellowstone file. This will create a new layer.
3. Choose the text tool and type the work FALL on the image. This will create a third layer. Open the character palette and increase the font size. We want the font big enough to be able to see the image above it through it. Move the text layer down below the fall layer. The text layer is the clipping layer and needs to be under the layer to be clipped.
4. While holding down the Alt key, place the cursor on the line between the fall layer and the text layer. When it turns into a little lock icon, click. This creates the clipping group.
Exercise 5 – Grayscale with one color

To create an image with a majority of grayscale coloring but have one item stand out in color.

1. Open an image.
2. Duplicate the background layer name it mask.
3. From the Image menu, choose Adjustments and Hue and Saturation.
4. Lower the saturation to -100.
5. Select the background layer and make a selection of the item you want to be in color.
6. Select the mask layer.
7. From the Selection menu choose Inverse to invert the selection you made.
8. Using the layer palette, choose the add layer mask icon.
9. If you want to increase the color of the grayscale area, lower the opacity on the mask layer.