Dreamweaver CS4
AP Divs (fka:Layers) and Behaviors

Email: 
training@health.ufl.edu

Web Page: 
http://training.health.ufl.edu
Dreamweaver CS4

AP Divs (Layers) and Behaviors

What are AP Divs and how can they benefit me? .......................................... 5
When to use AP Divs instead of Tables .......................................................... 5
Creating AP Divs ......................................................................................... 6
Selecting, Moving and Resizing AP Divs ....................................................... 6
Grids and Rulers .......................................................................................... 7
Property Inspector ....................................................................................... 7
AP Divs Panel .............................................................................................. 8
Layer Names ............................................................................................... 8
Visibility ...................................................................................................... 8
Stacking Order ........................................................................................... 8
Overlapping and Nesting ............................................................................. 9
Content ......................................................................................................... 9
Content Overflow ........................................................................................ 9
Clipping Area ............................................................................................. 10
Converting AP Divs to Tables ...................................................................... 10
Behaviors ..................................................................................................... 11
Adding behaviors ......................................................................................... 11
Show-Hide Behavior .................................................................................. 12
Open New Browser Window ........................................................................ 12
Fly out Menus ............................................................................................. 13
Delete and Editing Behaviors ..................................................................... 14

Diane Millican
Training Specialist
HSC Information Technology Center

352-273-5051
E-mail: dmillc@ufl.edu
training@health.ufl.edu
http://training.health.ufl.edu
AP Divs and Behaviors

What are AP Divs and how can they benefit me?

AP Divs are very similar to a table cell. In Dreamweaver AP Divs can be used for layout or to add special effects. AP Divs allow for pixel specific positioning of elements in web pages using x,y coordinates similar to a graph except AP Divs start from the top and left of the page. Beginning in Dreamweaver CS3 what used to be called Layers are AP Divs. That stands for Absolutely Positioned Divs. A Div is a block element HTML tag that can pull content (text, images, etc.) out of the flow of the document. Think of a Div as a container for your content.

AP Divs are like individual web pages and anything that can be placed on a web page, such as text, graphics, video, and tables, can be placed in individual AP Divs. AP Divs also allow for overlapping elements on a web page. Before CSS, a web page could only have two “Layers”, the background and the content.

Adding behaviors gives the ability to show and hide AP Divs to create interactivity of the web pages. Behaviors can be adding sound or pop up browsers or fly out menus. Behaviors can be added to many HTML elements.

When to use AP Divs instead of Tables

Tables should be used when you are working with data. For accessibility, using tables for layout is being increasingly discouraged. Dreamweaver allows pages created with AP Divs to be converted to table layout and those created with tables can be converted to AP Divs. So you could design your page with AP Divs and change to tables, but you would lose the interactivity and overlapping, seeing only the content. Another choice might be to make two versions of your page, one with AP Divs and one with tables for viewing with older browsers.

In order to see AP Divs, the viewer must be using a browser of version 4 or later. Statistically, per the W3schools web site statistics (http://www.w3schools.com/browsers/browsers_stats.asp) most of your audience will probably have a newer version browser. And certainly, if you are creating a web page geared toward a more technologically savvy audience they would have a newer browser that would render AP Divs fine.
Creating AP Divs
AP Divs can be created in different ways.

From the **Layout Insert panel** choose the **draw AP Div** icon

- Make sure the **Layout Insert bar** is in **Standard Mode**
- The cursor changes to crosshairs
- Click at the top left corner of where the layer is to be located
- Drag the cursor to create the size layer needed
- When you let go of the mouse button, the layer is created.

From **Insert menu** option choose **Insert > Layout Objects > AP Div**
- By Default a layer is inserted at the insertion point (cursor)
- The default layer can then be moved and resized

AP Divs are normally coded with a `<div>` tag. A `<div>` tag is a block element, meaning it moves it out of the line before and after. By itself, a Div tag changed nothing on the page. It creates a wrapper for what is inside of it, but without applying CSS to a div it does not make any changes to the page. An AP Div has positioning attributes attached to it as soon as it is created. It is placed exactly where you put it on the page. If you have a left attribute of 50px it will be 50 pixels from the left of the page.

**Selecting, Moving and Resizing AP Divs**

To **select** a layer, move the cursor over the AP Divs edges. Click when the cursor turns into a four headed arrow. You should see a selection handle and several small sizing handles.

Click on the selection handle and drag to **move** the layer around on the page. Click and drag each sizing handle to **resize** the layer.
To **Delete** the layer, select it and hit the delete key. Hovering over a selected layer gives a pop up with the AP Divs attributes.

**Grids and Rulers**

To make placement and sizing easier, Dreamweaver provides rulers and a grid on the document.

To turn those on, go to the menu option **View > Rulers > Show** or **View > Grid > Show**. These are toggle keys, so do the same thing again to turn them off.

You can set properties such as colors, dots or lines, and spacing by going to **View > Grid > Grid Settings**.

**Property Inspector**

Another way to position and resize AP Divs is to go to the **property inspector**.

![Property Inspector Screen Shot](image)

In the property inspector, you can name the layer in the Layer ID text box, and set the exact pixel location of the layer from the **Top Left** corner of the web page. Just enter the number of pixels from the Left side in the **L** box and the number of pixels down from the top of the page into the **T** box. You can also enter the size by entering the pixels dimension of the **Width** and **Height** of the layer.

AP Divs are normally positioned absolutely. **Absolute positioning** takes the element out of the flow of the document and positions it relative to the Top Left corner of the document with no regard to what else in on the page. If a layer is positioned **relatively** it does affect the flow of the document.
**AP Divs Panel**

The **AP Divs panel** lists all the AP Divs on the page and gives you a place to manage your AP Divs. There are three columns in the AP Divs panel. The **eyeball** (visibility status) column, the **ID (Name)** column and the **Z** (stacking order) column.

**AP Div Names**

By default the AP Divs are named apDiv#x when they are created. To change the name for ease of use and manageability, double click on the name and type a descriptive and meaningful name. Or change the name in the property inspector in the CSS-P Element box.

**Visibility**

By default a layer is normally visible when the page loads unless it is acted upon by a behavior. In the eyeball column

- No eyeball is the default, visible unless acted upon in some way**.
- An open eye is a visible layer
- A closed eye is a hidden layer

To change the visibility just click in the column next to the layer under the eye symbol until it is the proper icon. Clicking the header row eyeball will toggle all the AP Divs visible or hidden.

**If you want to be sure a layer is visible on load it may be best to set it as visible as some browsers may not have the default as visible.**

**Stacking Order**

Stacking order determines which layer is on top of other AP Divs if they overlap (prevent overlapping by checking the **Prevent Overlaps** check box).

The layer with the lowest Z value will be on the bottom of the stack. A higher Z value will go on top and may hide all or part of the layer underneath it.

AP Divs are given increasing values as they are created, but they can be changed by clicking and dragging the layer to the proper position. Or change the Z value and the layer will change position. **Layer numbers do not need to be consecutive, but the higher numbers will be on top of the lower numbers.**
Overlapping and Nesting

AP Divs can be overlapped with one layer partially or completely covering the layer underneath. Or AP Divs can be nested. A nested layer is a "parent" layer and a "child" layer and the child layer is positioned in relation to the parent. Nested AP Divs will move together. Nested AP Divs can be separate or overlapping.

To create a nested layer:
- Select the parent layer
- Hold down the Alt key while dragging the new layer
- The nested (child layer) will show indented under the parent layer.

To nest existing AP Divs:
- Select the layer to be nested (child) in the AP Divs panel
- Hold down the Ctrl key and drag the layer to the parent layer and when you let go the layer will show indented to signify nesting

When nested, you can still move the child layer, but if you move the parent layer when you let go of the mouse button the child layer will move into the same relative position.

If you delete the parent layer the child AP Divs deletes also.

To un-nest: select the child layer in the AP Divs panel and hold down the Alt key and drag it away from the parent layer.

Content

A layer can hold nearly any HTML content. To add content to a layer, first select the layer. Click inside the layer to position the insertion point within the layer and add the content as you would to any web page. This means using the Insert menu, the Insert Panel or dragging and dropping from the files panel.

Content Overflow

AP Divs will stretch to accept the content unless they are set to a specific size. If a layer is set to a specific size, and you have content overflow, you can set how that overflow will be handled. On the property inspector there is a drop down box to set the overflow setting at visible (to show all no matter the size), hidden (to hide the overflow), scroll (add scroll bars so the layer stays the set size, but the viewer has the option to scroll through the content. This overflow choice will not be obvious while you are in Dreamweaver; you have to preview it to see how it will look in the browser. If you don’t set a value, the browser will stretch the layer and show all of the content.

Hiding overflow could be used if overlapping images are not exactly the same size. By hiding the overflow you ensure all the images will show in exactly the same width and height.
Clipping Area

The clipping area of a layer is the visible part of the layer or what will be seen by the viewer in a browser. A large image can be clipped to a smaller area and the rest of the file will still be there, but will not be seen.

The image above is clipped to start at 100 pixels from the left edge of the layer and ends at 175 pixels from the left edge. It starts 50 pixels from the top of the image and stops at 250 pixels from the top. Set overflow to hidden. This is not a way to shrink a file as the full file is still there, just not visible.

Converting AP Divs to Tables

You may want to save your page for viewers using older browsers in tables in addition to the page created with the AP Divs.

To convert from AP Divs to a table layout

- Open the page to be converted
- From the Menu choose Modify > Convert > AP Divs to Tables
- Save the new page
Behaviors

To make a web page more dynamic and interactive, Dreamweaver allows behaviors to be added to many HTML elements. With AP Divs, behaviors allow us to show and hide AP Divs as we choose. The Show-Hide behavior can be attached to anchors (links), images, and form fields.

Adding behaviors

To add a behavior to an element:

- Open the Behaviors panel if it is not opened (From the Window Menu)
- Select the element (or tag) that is to activate the behavior
- Click on the Add Action button +
- A drop down menu will open with behavior options to choose
  - These options are content sensitive
- After choosing the behavior, go to the events column in the Behavior panel
- Choose the desired event – onClick, onMouseOver, etc.
- You can add more than one action to a single element.
Show-Hide Behavior
Dreamweaver has a rollover action set up to swap out two images. If we want to swap more than two images in one space we can use AP Divs and the **show-hide** behavior to accomplish this.

- Set up your page with each image in the same exact location on different AP Divs (exact same pixel locations)
- Set each layer’s visibility to **hidden** so the page will load without the images showing
- Create null links for each image (layer)
- Select the link, click on the add behavior button +
- Add the **show-hide** behavior
- Determine which AP Divs to show or which to hide
- Choose event handler for this lesson use:
  o onMouseOver show layer
  o onMouseOut hide layer
- Save your page and preview it in your browser

![Show-Hide Layers dialog box](image)

This dialog box shows hiding layer2.

Open New Browser Window
To add a behavior to open up a pop up window such as a map for directions:

- Create a null link
- Select link to add behavior
- In the behavior panel, add the open browser window behavior
- In the pop up dialog box
  o Enter URL of page to display
  o Make choices as to size, scroll bars, resize handles, etc
  o Create a window name with no spaces or special characters
  o Click OK
- Save the page and preview in the browser and test link

![Open Browser Window dialog box](image)
Fly out Menus
To create a menu that flies out onMouseOver, create the base for the menu. This could be simple text (Training Links) or it could be an image. Create a null link on the base item. Create a layer that overlaps but does not cover the base.

Inside the layer, insert a one column, one row table with no padding or spacing and width of 100%. Give it a background color. Click inside the table and insert a second table for the menu, include a row for each link you want to add. One column should be fine. Give it a small amount of cell spacing (1 or 2 pixels) and 100% width. You can alternate row background colors.

Put one menu item in each row. Add hyperlinks.

Make the layer hidden. Then add a behavior to the original base item (text or image). Use the show-hide layer behavior and show the layer onMouseOver. You can add another behavior to hide the layer onMouseOut, but then you could not click on the menu items. So a trick is to add two other areas (use a small image) above and below the original base item and apply a behavior to them to hide the layer onMouseOver. This allows the layer to show as soon as you MouseOver the original base and will stay visible until you MouseOver the other images.
The base (This case the base is text) and the two alternate images.

This shows the base and the flyout menu. This is from the Dreamweaver application, so it is showing the layer boundary lines.

**Delete and Editing Behaviors**

To delete a behavior:
- Select the item where the behavior is attached
- In the Behaviors panel, click on the behavior you want to delete.
- Click on the – or press delete on your keyboard

To edit a behavior:
- Select the item where the behavior is attached
- In the Behaviors panel, double click on the behavior to be edited.

Sometimes an item may have several behaviors that should happen in a particular order. If they are not in the correct order they can be reordered.

To reorder behaviors:
- Select the item where the behavior is attached
- In the Behaviors panel, select the behavior to reordered.
- Click on the up ▲ and down ▼ arrows to move the order.