Adobe Acrobat 8 Professional Forms
This page intentionally left blank.
Table of Contents

Forms .................................................................................................................................................... 2
Creating forms ........................................................................................................................................ 2
Forms Toolbar ....................................................................................................................................... 2
Add Form Fields to the .pdf document .......................................................................................... 3
  General Tab ...................................................................................................................................... 3
  Appearance Tab ............................................................................................................................ 4
  Options Tab .................................................................................................................................... 4
  Actions Tab ..................................................................................................................................... 5
  Format Tab ...................................................................................................................................... 6
  Validate Tab ..................................................................................................................................... 6
  Calculate Tab .................................................................................................................................. 7
  Calculation Preferences ................................................................................................................ 7
Form Field Characteristics ................................................................................................................ 8
Creating multiples ............................................................................................................................. 9
Positioning and Aligning fields ......................................................................................................... 9
Selecting Fields .................................................................................................................................. 9
Submit the Form .............................................................................................................................. 10
Returning the information by email – Users view .......................................................................... 11
Create Spreadsheet from data files ............................................................................................... 12
Form Field Recognition .................................................................................................................. 13
**Forms**

We use forms all the time for gathering information. Many forms are created in programs like Word or in a design program such as InDesign or Publisher. These forms look great and are good if you want to print the form out and fill it in, but more frequently we want the ability of creating the forms, sending them by email and having them filled out online and the information returned to us, either by email or into a database. And we want everyone regardless of computer platform or operating system to be able to have access to our forms.

In this workshop we will learn how to create the forms and how to get the responses returned by email.

**Creating forms**

One way to share forms across different platforms is to use Adobe Acrobat Professional. Once the static items of the form are created in a word processor program or a design program, convert it to a .pdf file (Adobe portable document file) and you are ready to add form fields. If your form has been created in MS Word, save as a .doc file in the same folder that you plan on saving your .pdf file. This will give you a copy of the file that can be amended and altered as needed. Another way to create a form is to scan an existing document and create a .pdf file.

New to Acrobat 8 is form field recognition. This will be discussed further on in the documentation. Most often you will have to add the form fields to your pdf document so it will be usable by others.

**Forms Toolbar**

<table>
<thead>
<tr>
<th>A. Button Field</th>
<th>B. Check Box</th>
<th>C. Combo Box</th>
<th>D. List Field</th>
<th>E. Radio Button</th>
<th>F. Text Field</th>
<th>G. Digital Signature</th>
<th>H. Barcode Tool</th>
<th>I. Distribute Form Tool</th>
</tr>
</thead>
</table>

Form Fields
- A. **Button Field** - Initiates actions such as clear form, submit form, print form.
- B. **Check Box** - User can choose one or more options.
- C. **Combo Box** - User can choose from a list or enter custom information
- D. **List Field** - User can choose one or more choices in a list
- E. **Radio Button** - User can make a single choice among several options
- F. **Text Field** - User can type in information requested
- G. **Digital Signature** - Creates a special field to add a digital signature to the document
- H. **Barcode Tool** - Add barcode to the document
- I. **Distribute Form Tool** - Distribution of the form
If you don’t see a Forms toolbar go to the Tools Menu choose Forms and then Show Forms Toolbar.

Or you can right click anywhere on a blank space in the toolbar area. That will show you all the available toolbars. Click Forms to turn on the Forms Toolbar.

Add Form Fields to the .pdf document

To add the fields to your form document, click on the type of form field you want to add from the Forms Toolbar. Bring your cursor to where on the document you want the field to appear. Click and drag to “draw” the field on your document. When you are done a new Field Properties dialog box opens. The dialog boxes are content sensitive, so different boxes will be available or offer different options depending on the field you have chosen to add. Field Properties box offers different tabs to choose from offering different design attributes.

General Tab

Click on the General tab and add a name for each field and if needed a tooltip may be added. The tooltip will pop up when the user hovers over the field. All fields have a General tab.

The Locked checkbox locks the field so the design attributes cannot be changed unless the Locked box is unchecked.
Appearance Tab
Click on the Appearance tab and choose how you want the field to appear on the document. Add borders and/or fill colors if desired and adjust text font and size. The appearance tab will appear for all field types. Auto in the Font Size text box means the text will size to fit the box you create and will get smaller as the user adds more text.

Options Tab
In the Options section, there are several choices of how your field will look or function. For example: alignment, scroll text and limiting the number of characters. If you have a text box field where the user is to add an address you may want to limit the state field to two characters allowing only the abbreviation can be entered. Your tooltip for this field may be “Enter two-letter state abbreviation”. If you think a majority of responders will enter a particular value, you may set up a default that will display on opening but allows for changes.

The options dialog box will change depending on the type of field you are creating.
Actions Tab

Actions can be added to form fields. An action could be opening another file or going to another page in a document. An action must have both the trigger to cause the action and the action. Each of these items must be defined. Use the drop down menus to define your actions and triggers. This might be particularly useful on button fields.

1. Select a trigger
2. Select an action
3. Click on the add button
4. Choose fields or files or add URL as needed in the dialog box that opens
Format Tab

The format category allows formatting of the information that is to be entered to be set to a specific standard. Use the drop down menus to set these formats. For example, you can set how numbers are displayed and whether a symbol (dollar sign) is displayed. Or a date could be formatted to display a particular way or display date only or date and time. The text box field and the combo Box field will offer this tab.

Validate Tab

Form field information can be validated when entered by the user. If a field is to have only an amount in a certain number range, that range can be entered in the validation area. If a number out of range is entered, a dialog box will open up and tell the user to try again. Custom validation scripts can also be created and inserted here.
Calculate Tab
Form fields can be used to perform some mathematical calculations. For example, you can calculate total cost based on the per item cost times the entered value of the number of items. Choose the function you need and then the fields to be used. The functions available are:
- Sum
- Product
- Average
- Minimum
- Maximum

Calculation Preferences
Some form attributes can be set up in advance in Preferences. Open the Preference dialog box by going to the menu option Edit > Preferences and choose the Forms category. If you are going to do any calculations you want to make sure the Automatically calculate field values is checked.
If you want a box to show up when the user hovers over a text field, check Show border hover color for fields.
Form Field Characteristics

Some unique form field characteristics are:

- **Radio Buttons**
  Normally user is allowed to choose only one in each area. To make this function properly, name all of the buttons exactly the same. An easy way to accomplish this is to copy and paste the buttons and create as many as you need. Right click the original button and choose Edit > Copy, then right click and choose Edit > Paste. The new button will paste in the middle of the document and it will need to be moved into the correct placement. When you hover your cursor over the field it will change to a black arrow head. Click and drag to move the field.

  Export values are the information sent to a data file or a database. Each export value needs to be different.

  If you think that a particular button will be chosen by a majority of users you can set one of the buttons as the default.

- **Combo Boxes**
  Combo boxes give the user a choice from a list, but they also may be set to have different choices entered manually by the user. To allow manual entries check the Allow user to enter custom text box.

  To add items to the list, type the item in the Item text box and click on the Add button.

  To make one of the items the default, select it in the Item list area.

  A list box is similar, but does not allow the user to enter a choice manually. It will allow multiple choices by choosing one and ctrl + click on other choices.

- **Text Boxes**
  If text boxes are named the same they will all fill in when the first one of that name is filled in. For example if you have a two page document and the user types his name in the “name” text field on page one the “name” text field on page two will also fill in at the same time.
Creating multiples

We have created duplicates by copying and pasting, but if you want to make many duplicates you can create the original field and right click and choose Create Multiple Copies. This would be really helpful if you were creating an order form for example. Instead of having to create and design each field individually you can make many copies all at once. Change the number of fields across and down to the number you want to create. If you check the preview box and move the dialog box out of the way, you can see the placement of the copies. To spread the fields apart increase the Width. To move them all click on the Overall Position buttons.

When creating multiples, the program gives each field a unique name by appending a number on the end of the original name.

Positioning and Aligning fields

To make the form look uniform, there are ways to align, center and size similar fields. Select at least two fields. (Select one and then Ctrl + click each succeeding filed)

Right click on one of the selected fields and chose whether you want to align or size, etc. the fields. Choose from the flyout menus and the fields will automatically arrange or size themselves accordingly. *The last object selected is the one that the size or location is based on.

Selecting Fields

Choosing a Form Field icon will show all of that type of field that is set up on the page. To show all types of form fields at once, choose the Select Object arrow on the Advanced Editing toolbar.
**Submit the Form**

Once you have the form designed, you may want to have the information sent back to you electronically. This can be done by creating a submit button. Create this button with the action **Submit a form**. Then you can add a script if one is available or you can have the information sent back to you by email.

If you are having the information sent back to you by email; when it asks for a URL use the format (no spaces!) `mailto:youremailaddress`. You could put someone else’s email here if they are supposed to get the information also. Put a ; between each email address no spaces. Choose the FDF Include for Export Format.

If you are using a script you would put the script address here. Use the Export Format that fits the script.

** The form can not be saved with the free Reader prior to Reader 8. It can be printed and the information can be returned, but the full form can not be saved. If you created the form and get the information back on the same machine, Acrobat will open the form and fill in the fields with the information that was returned.
**Returning the information by email – Users view**

When someone receives your form they can open it up and fill in the fields, then return the information by email. They will have the option to print the form as well.

Upon clicking the Send Data File button, the following dialog box will open.

If they are at their own desk and have an email client, they would choose the first option and the email will open and have the proper email address and the data file attached. All that is required by the user is to click the send button on the email.
If however, they do not have an email client and/or they are using Web (Internet) Mail they will have to choose the second option. Then the next dialog box will open.

**Sending the Data File**

1. **Step 1** Click the 'Save Data File' button below and save the data to a place where you can find it easily. After you save the file, you will be returned to this screen to continue.
   - Please Note: The form itself is not saved (only the data you typed)

2. **Step 2** Create a new email message as you normally would. If you use Internet email and are viewing this form online, open a new browser window so you can keep this window open. Fill in the email with the following information:
   - **To:** chi@bif.edu
   - **Subject:** Data from radon practice
   - **Message:** The attached file contains data that was entered into a form. It is not the form itself.

3. **Step 3** Attach the data file you saved in Step 1 and send your message.

This requires a little more interaction by the user.
1. Save the file containing the data they entered on the form. Note the email address to which the form needs to be returned.
2. Then open a new email message add the email address and subject
3. Attach the file they saved.
4. Send email.

**Create Spreadsheet from data files**

Once you have received the information back, Acrobat has included a way to create a spreadsheet so you can see all of the information you have collected.

- When you get the responses from your form, save each file. You may want to create a folder for the results for each form you create.
- Open the Acrobat program and from the **Forms menu** choose **Manage Form Data** and then **Merge Data files into Spreadsheet**.
- When the dialog box pops up choose **Add files**. Locate and add each file that you had returned to you for that form.
- **Export** them and a new box will pop up to allow you to save a csv (comma separated value file).
- Then choose View Now to open an Excel worksheet and view the information.
Form Field Recognition

New to Acrobat Professional 8, is **Form Field Recognition**. Once you create a form and make it a PDF, you can run form field recognition to have Acrobat insert form fields. From the **Forms Menu**, choose **Run Form Field Recognition**. It will look at the form and see if it can recognize anything that looks like a form field. If there are small boxes it may make them Check Boxes. If there are labels with lines after them it will most likely make a text field. Once Acrobat has added what it thinks are good form fields it will open the document up and give you the opportunity to fix fields not created well, or just edit with new names, etc. the fields that are there. The created form fields show up in a list on the left side in a Recognition Report. Clicking on any Field will highlight the field. When you are done you can close the Report with the X in the upper right hand corner. Using the Select tool you can double click on any field and open up the **Field Properties** Dialog Box to edit the fields.