Microsoft Excel 2010
Sorting and Filtering
Excel 2010: Sorting and Filtering

1.5 hours

In this workshop we will discuss working with large datasets within Microsoft Excel. We will work with single and multilevel sorting, and learn to use data filters to have Excel automatically show only the data we wish to see. We will work with the filtered data, including doing math on our filtered datasets. This workshop also contains a very brief introduction to other summary tools such as Subtotal and Pivot Tables.

Sorting Data .......................................................................................................................... 1

  Ascending Sorts ................................................................................................................ 1
  Descending Sorts .................................................................................................................. 1
  Custom Sorts ....................................................................................................................... 1
  Custom Lists ........................................................................................................................ 2
  Sort Options ........................................................................................................................ 2

Filtering Data ....................................................................................................................... 3

  Custom Filters .................................................................................................................... 4

SUBTOTAL Worksheet Function ............................................................................................ 5

Other Summary Tools .......................................................................................................... 6

  Subtotal Outlines ............................................................................................................... 6
  Pivot Tables ........................................................................................................................ 6

Class Exercise ...................................................................................................................... 7

Pandora Rose Cowart
Education/Training Specialist
UF Health IT Training

C3-013 Communicore
PO Box 100152
Gainesville, FL 32610-0152
(352) 273-5051
prcowart@ufl.edu
http://training.health.ufl.edu

Updated 5/22/2016
Sorting Data
On the far right side of the Home tab you will find the large Sort/Filter button. The menu you see when you click on the button is reflected in the Sort & Filter group of the Data tab.

If you make a selection of cells, Excel will think you only want to sort or filter by that selection. But if your dataset has no black rows and no blank columns Excel will see the whole block as one database.

You can have blank cells, but not completely blank columns/rows; if you are not sure that your dataset is consistent, click inside one cell, and press Ctrl-A. This will select all the values in the dataset.

When you have completed a sort, you can click the Undo button (or Ctrl-Z). Excel will undo the sort and it will select the dataset it used in the sort.

Ascending Sorts
- **Text**: Sort alphabetically from A to Z
- **Numbers**: Sorts from smallest number to largest number
- **Dates**: Sorts from the youngest date to the oldest date

Descending Sorts
- **Text**: Sort alphabetically from Z to A
- **Numbers**: Sorts from largest number to smallest number
- **Dates**: Sorts from the oldest date to the youngest date

Custom Sorts
When you first open this window, Excel will show the last sort you have set. If you haven't created a sort yet, this window may be blank.

In earlier versions of Excel we only had three levels to sort by. In Excel 2010 we can sort by up to 64 levels. From this sort window we can add levels, delete levels, copy levels and even change the order of our sort using the up and down arrows.
Column: The column drop down menu will show the names of your columns, your ‘fields’. If your data doesn’t have these headers Excel will list the Column letter instead. If it had names, but is only showing the column letters, you can click on the check box in the upper right hand corner to let Excel know your data has headers.

Sort On: You can Sort on the values of the cells, the cell colors, the font colors, or the cell icons.

Order: The order options change depending on the values in the cells.

- **Text**
  - A to Z
  - A to Z
  - Z to A
  - Custom List...

- **Number**
  - Smallest to Largest
  - Largest to Smallest
  - Custom List...

- **Date**
  - Oldest to Newest
  - Newest to Oldest
  - Custom List...

- **Font Color**
  - Automatic
  - On Top

- **Cell Color**
  - No Cell Color
  - On Top

*Custom Lists*
Custom lists can be built through the Excel Options under the **File** menu in the **Advanced** section under **General**.

- **Sort Options**
  - **Case sensitive**: Sort lowercase letters before uppercase letters
  - **Orientation**: Sort horizontally (left to right) or vertically (Top to bottom)

Months and Days already exist as custom lists. If you had months listed and sorted ascending (A-Z) April would come before January.

Notice the **Custom List…** option at the bottom of each order box above. If you choose this option you will be able to select from one of these lists. Alphabetically, April comes before January. With the Custom List order, we can ensure January comes first.
Filtering Data
Filters hide rows (records) based on criteria you set. You can turn the filter on and off by choosing Filter from the Sort & Filter button on the Home tab, or choosing the Filter button on the Data tab.

Excel will place a drop-down arrow at the end of each cell in the header row (the first row). When you click on this arrow we see several options including our sort orders:
- Sort Ascending, Descending, and by color
- Clear the Filter
- Filter by Color
- Set a custom filter (text, number, date)
- Search for a matching value in the column
- Choose from a list of values in the column. Select All will toggle between everything and nothing. Uncheck a value to hide it on the sheet.

Once a filter has been set Excel will hide all the rows that don't match the criteria you set. The status bar will show how many records (rows) were found that did match. The row numbers of the original data will remain the same, but will appear blue. The dropdown arrows of the columns that are being filters will also appear blue.
**Custom Filters**

Depending on the data in the column you will have the option to set a filter based on text, numbers and dates.

<table>
<thead>
<tr>
<th>Text Filters</th>
<th>Number Filters</th>
<th>Date Filters</th>
</tr>
</thead>
<tbody>
<tr>
<td>Equals...</td>
<td>Equals...</td>
<td>Equals...</td>
</tr>
<tr>
<td>Does Not Equal...</td>
<td>Does Not Equal...</td>
<td>Before...</td>
</tr>
<tr>
<td>Begins With...</td>
<td>Greater Than...</td>
<td>After...</td>
</tr>
<tr>
<td>Ends With...</td>
<td>Greater Than Or Equal To</td>
<td>Between...</td>
</tr>
<tr>
<td>Contains...</td>
<td>Less Than...</td>
<td>Tomorrow</td>
</tr>
<tr>
<td>Does Not Contain...</td>
<td>Less Than Or Equal To...</td>
<td>Today</td>
</tr>
<tr>
<td>Custom Filter...</td>
<td>Between...</td>
<td>Yesterday</td>
</tr>
<tr>
<td></td>
<td>Top 10...</td>
<td>Next Week</td>
</tr>
<tr>
<td></td>
<td>Above Average</td>
<td>This Week</td>
</tr>
<tr>
<td></td>
<td>Below Average</td>
<td>Last Week</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Next Month</td>
</tr>
<tr>
<td></td>
<td></td>
<td>This Month</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Last Month</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Next Quarter</td>
</tr>
<tr>
<td></td>
<td></td>
<td>This Quarter</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Last Quarter</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Next Year</td>
</tr>
<tr>
<td></td>
<td></td>
<td>This Year</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Last Year</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Year to Date</td>
</tr>
<tr>
<td></td>
<td></td>
<td>All Dates in the Period</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Custom Filter...</td>
</tr>
</tbody>
</table>

If you choose one of the options on the Filter List with the ellipsis (...), you will see a Custom Auto Filter window such as this. From here we can set up to two filters.

Be careful with the AND/OR relationships. If you ask Excel to show the rows where the City equals Micanopy AND the City equals Gainesville, you will get no results, because one cell cannot equal both values. But if you ask for the same using the OR, Excel will show all the records for both cities. Or’s tend to work for exact matches (Equals This OR Equals That), whereas AND's tend to work for ranges (Greater than This AND Less than That).

You can use the “Wildcards” ? and * to help you with your filter. ? is used for one character, * for multiple.

Equals Jacks* -> Jacksonville, Jacksonville Beach, Jackson Heights

Some of the filter choices may work just as well. I could say Contains 'Jacks' or Begins with 'Jacks'.
**SUBTOTAL Worksheet Function**

We can do common mathematical functions with our filtered lists using the SUBTOTAL worksheet function. The syntax is for this function is "SUBTOTAL(function_num,ref1,ref2,...)". Function_num is the number 1 to 11 that specifies which 'function' to use in calculating subtotals within a list (see below). The ref1, ref2... are the ranges of data that should be used in the equation, there can be up to 29 different ranges used in this function.

<table>
<thead>
<tr>
<th>Function_Num</th>
<th>Function</th>
<th>Function_Num</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>AVERAGE</td>
<td>7</td>
<td>STDEV</td>
</tr>
<tr>
<td>2</td>
<td>COUNT</td>
<td>8</td>
<td>STDEVP</td>
</tr>
<tr>
<td>3</td>
<td>COUNTA</td>
<td>9</td>
<td>SUM</td>
</tr>
<tr>
<td>4</td>
<td>MAX</td>
<td>10</td>
<td>VAR</td>
</tr>
<tr>
<td>5</td>
<td>MIN</td>
<td>11</td>
<td>VARP</td>
</tr>
<tr>
<td>6</td>
<td>PRODUCT</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

SUBTOTAL will ignore any hidden rows that result from a list being filtered. This is important when you want to subtotal only the visible data that results from a list that you have filtered. Often displaying the totals above your filtered lists works best, see the example below.

![Example Table 1](image1.png)

![Example Table 2](image2.png)
Other Summary Tools

Subtotal Outlines
One way to sum up a large set of data is to use the Subtotal tool in the Outline group of the Data tab. This tool will total sets of related data and insert a subtotal into the sheet at each change in the column of your choosing. It will also create a grand total at the bottom of the dataset.

This tool is very particular about your sort order. If you are going to group a column, make sure it is sorted first.

Also pay attention to the Replace Current Subtotals option, as it does erase the previous totals.

Excel adds outline symbols to the left side of the worksheet. The numbers represent the outline level, the plus is used to expand a group, and the minus is to collapse a group.

Pivot Tables
Another amazing summary tool built into Microsoft Excel is the Pivot Table. You’ll find this button at the beginning of the Insert tab.

By default this tool will create a new sheet with a blank table on it. You can use the Pivot Table field list to decide where your field names (column headings) should go, and Excel will move them to the desired location, summarizing the values as needed.
Class Exercise

- Open file SortCustomers.xlsx
  Workshop files can be found here:  
  http://training.health.ufl.edu/excel2010_handouts.aspx

Simple Sorts

- Click in the title CITY in cell D1
- Home Tab -> Sort and Filter -> Sort A to Z (ascending)
- Undo
- Sort is "undone" and selection that was sorted is highlighted.
- Select Column D (city)
- Home Tab -> Sort and Filter -> Sort A to Z (ascending)
- Say OK to the message
- Undo

Default Sort Order

- Select Column A (LAST)
- Insert a Column
- Title the new column SORT (A1)
- In A2 Type the number 1
- In A3 Type the number 2
- Select both numbers
- Double-click the fill handle to copy the pattern to the end of the data set
- Sort by CITY
- Sort by SORT
- Delete Column A

Blank Columns

- Select Column B (FIRST)
- Insert a Column
- Sort by CITY Z to A (descending) - Notice the first and last names no longer match up
- Undo - Notice the last name column is left out of the group
- Give Column B a title: SUFFIX
- Sort by City Z to A
- Undo until the new column (SUFFIX) is gone
**Custom Sort - Multiple levels**
- Click on the large sort button on the Data tab
- Set the sort order for CITY, BALANCE, and DUE DATE
  - Use the Add Level buttons to create new lines
- View the Results

**Custom Sort - Rearranging**
- Open the Custom Sort again
- Select the DUE DATE row and use the arrows to move it
- Set the sort order for CITY, DUE DATE, and BALANCE
- View the Results

**Custom Sort - Resetting**
- Click in the column A (LAST)
- Click the Ascending button
- Open the Custom Sort window
  - Sort order has been reset

**Custom Sort - by Color**
- Open the Custom Sort window
- Sort by Address, Sort on Cell Color, Order Green On Top
- **Copy Level** and set the Order to Peach on top
- **Add Level** -> Balance, smallest to largest

![Custom Sort Window](image)

- View the Results

**Reset to our default sort order**
- Click in the column A (LAST)
- Click the Ascending button
**Custom Sort - Left to Right**

- Open Custom Sort Window
- Click on the Options... button
- Change orientation to **Sort left to right**
- Click OK
- Sort by Row 1, A to Z

![Custom Sort Window](image)

- Columns have rearranged to **Address through Zip**
- Select Row 2, and Insert a row
- Number the cells: 3, 8, 4, 7, 1, 2, 5, 6

![Sorted Table](image)

- Open Custom Sort Window
- Sort by Row 2
- View the result

**Custom Sort - Left to Right - Selection**

- Select Columns A and B (FIRST and LAST)
- Open Custom Sort window
- Sort by Row 2, Largest to Smallest
- Repeat for Columns G and H (DUE DATE and BALANCE)
- Delete Row 2

**Reset to our default sort order**

- Click in the Column A (LAST)
- Click the Ascending button
- LAST has shuffled down to the L's
- Undo the sort
**My data has headers**

- Open the custom sort window
- Sort by only lists the column letters for the 8 columns in our dataset
  - (if it is still offering rows, change the options)
- In the upper right of the window click the **My data has headers** checkbox
- Sort by LAST, A to Z

**Start over**

- Exit Microsoft Excel
- **DO NOT SAVE**

**Instant Filter**

- Open SortCustomers.xlsx
- Right-click on a city of **Waldo**
- Choose Filter -> Filter by selected cell's value

---

*** Filter arrows appear on all columns of the data set
*** All rows not matching the criteria have disappeared
*** Row numbers turn blue, but maintain original cell numbers
*** Bottom of the window shows how many records (rows) match
*Turn the Filter Off*
- From the **Sort & Filter** button on the **Home** tab, choose **Filter**
  *** All filter signs will disappear

*Filter by Unchecking*
- Click the large **Filter** button on the **Data** tab
- From the **City** drop down, uncheck **Micanopy**, click OK
- From the **City** drop down, uncheck **Gainesville**, click OK
- From the **City** drop down, check **Select All**, click OK

*Filter by (Un)Select all*
- From the **Zip** drop down, uncheck **Select All**
- From the **Zip** drop down, check **32608**, click OK

*Adding another filter*
- Keep the **32608** filter
- From the **City** drop down, uncheck **Micanopy**, click OK
- From the **Data** tab, choose the filter **Clear** button

*Custom number filter*
- From the **Balance** drop down, choose **Number Filter**
- Choose Less than, type in **100**, click OK
- **Clear the filter**

*Date filter*
- From the **Due Date** drop down, uncheck **Select All**
- Use the expand (+) buttons to open the dates
- Check the first three months of 2014, click OK

*Custom date filter*
- From the **Due Date** drop down, choose **Date Filter**
- Choose Between, type in **7/1/2013**, type in **6/30/2014**, click OK
- **Clear the filter**
**Custom text filter**

- From the **Last** drop down, choose **Text Filter**
- Choose **Begins with**, type J, click OK

- From the **Last** drop down, choose **Text Filter**
- Choose **Ends with**, type S, click OK

- From the **Last** drop down, choose **Text Filter**
- Choose **Begins with**, type J
- On the second line choose **Ends with**, type S, click OK

- From the **Last** drop down, choose **Text Filter**
- Choose **Custom Filter**
- Change the bubble (radio button) to **OR**, click OK

- **Clear the filter**

**Custom text filter**

- From the **Address** drop down, choose **Text Filter**
- Choose **Contains**, type Box, click OK

- **Clear the filter**

- From the **Address** drop down, click inside the **Search** box
- Type box
- **** Type it slowly, one letter at a time to see the list get smaller as you go
- Click OK
- **Clear the filter**
Filter by Color
- From the Address drop down, choose Filter by color
- Choose the green addresses
- Clear the filter

Refreshing Filtered Data
- From the Balance drop down, choose Number Filter
- Choose Greater Than, type 600, click OK
- Change Edgar's balance to 300
- From the Data tab, choose the filter Refresh button
- Clear the filter

Copying filtered data
- Use the filter tools to find these 8 records:
  - Balance under 200
  - Address color has no fill
  - Due Date in 2012
- Select All, Copy
- Turn to Sheet 2, paste in Cell A1

- Return to Sheet 1 and Clear the filter
- Use the filter tools to find these 8 records:
  - Balance over 425
  - Due Date in 2011
- Select All, Copy
- Turn to Sheet 2, paste in Cell A12

- AutoFit the column widths

Filter on one data set
- Move to Cell A1
- Turn on the filter
- From the City drop down, uncheck Gainesville, click OK

****Gainesville only disappears from the first list because of the gap
- Turn off the filter
Filter on multiple data sets
- Select all the data columns (not just the data, all the columns)
- Turn on the filter
- From the City drop down, uncheck Gainesville, click OK
  ****Gainesville disappears from both lists, but the record count is wrong
- Clear the filter

Filter including gap
- From the City drop down, uncheck Select All
- From the City drop down, check Gainesville, click OK
- From the City drop down, check (Blanks), click OK
- From the City drop down, check City, click OK

- From the City drop down, uncheck Gainesville
- From the City drop down, check Micanopy, click OK

Start over
- Exit Microsoft Excel
- DO NOT SAVE

Set up Grand Total
- Open file SortCustomers.xlsx
- Turn on the Filter
- Go to Cell H79, Type SubTotal
- Go to Cell H80, Type Total
- Go to Cell G80, press the AutoSum button ∑ (on the Home or Formulas tab)
- Modify equation to stop at row 78
  **** =SUM(G2:G78)

Set up SubTotal
- Filter data set to only show people in the City of Waldo
- Go to Cell G79, press the AutoSum button ∑
  **** See Page 5 for details on the SubTotal Worksheet Function
- Clear the filter
**Viewing the different Subtotals**

- From the City drop down, set it so you can only see Starke
- From the City drop down, set it so you can only see Micanopy
- From the City drop down, set it so you can only see Gainesville
- **Clear the filter**

- Exit Microsoft Excel
- **DO NOT SAVE**

**Practice Exercise**

- Open file SortSales.xlsx
  Workshop files can be found here:  

1) Insert four rows at the top of the worksheet
2) Type in the titles

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Sum</td>
<td></td>
<td>SubSum</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Average</td>
<td></td>
<td>SubAvg</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Count</td>
<td></td>
<td>SubCount</td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Quarter</td>
<td>Item</td>
<td>Size</td>
<td>Color</td>
<td># Sold</td>
</tr>
<tr>
<td>5</td>
<td>1st Quarter</td>
<td>blouses</td>
<td>Large</td>
<td>Blue</td>
<td>14</td>
</tr>
</tbody>
</table>

3) Click inside the dataset, turn on the Filter
4) Use the filter tools to find these 3 records:
   - Quarter: 2nd Quarter
   - Item: Pants
   - Color: Red
5) **Build the following equations**

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Sum</td>
<td>=SUM(E5:E168)</td>
<td>SubSum</td>
<td>=SUBTOTAL(9,E5:E168)</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Average</td>
<td>=AVERAGE(E5:E168)</td>
<td>SubAvg</td>
<td>=SUBTOTAL(1,E5:E168)</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Count</td>
<td>=COUNT(E5:E168)</td>
<td>SubCount</td>
<td>=SUBTOTAL(2,E5:E168)</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Quarter</td>
<td>Item</td>
<td>Size</td>
<td>Color</td>
<td># Sold</td>
</tr>
</tbody>
</table>

6) Clear the filter, the numbers in Column E should match the numbers in Column B