Microsoft Excel 2010
Linking Worksheets & Workbooks
Microsoft Excel 2010: Linking Worksheets & Workbooks

1.5 hour

Topics include inserting, deleting and renaming worksheets; linking worksheets; editing and printing multiple worksheets and linking workbooks. This workshop assumes some prior experience with Excel. Completion of "Excel: Basics I" is recommended.

Number of Worksheets........................................................................................................1
Inserting Worksheets..................................................................................................................1
Deleting Worksheets..................................................................................................................2
Renaming Worksheets ................................................................................................................2
Color Coding Worksheets ..........................................................................................................2
Moving and Copying Worksheets ..............................................................................................3
Hiding Worksheets ....................................................................................................................3
  Unhiding Worksheets ...............................................................................................................3
Selecting Multiple Worksheets ..................................................................................................4
  Range of Worksheets ...............................................................................................................4
  Selecting Specific Worksheets ..................................................................................................4
  Selecting All the worksheets ....................................................................................................4
  Unselecting Worksheets ............................................................................................................4
Linking Cells ...............................................................................................................................5
  Create a Link ............................................................................................................................5
    Using the Clipboard ................................................................................................................5
  Remove a Link ..........................................................................................................................5
    Absolute vs. Relative ...............................................................................................................5
Linking Workbooks ....................................................................................................................6
  Opening Linked Files ...............................................................................................................6
  Handling Broken Links ............................................................................................................7
  Edit Link Window .....................................................................................................................7
Working with Multiple Files/Windows .......................................................................................8
  Ungrouping Taskbar Buttons ..................................................................................................8
  Moving Between Windows .......................................................................................................8
  View Different Sheets of the Same Book .................................................................................8
Class Exercise ..........................................................................................................................9

Updated: 5/22/2016
**Number of Worksheets**

An Excel workbook can contain up to 255 worksheets. By default, new workbooks have three worksheets. These sheets can be renamed, rearranged, deleted, and more can be added.

You can change the default setting from the Excel Options. The Options button is at the bottom of the File menu. In the General group of the Excel Options you can set the number of sheets to be opened in a new workbook.

You can set new books to start between 1 and 255 sheets. Changing this setting will not modify the current workbook, only future new workbooks.

**Inserting Worksheets**

You can insert a worksheet by doing one of the following:

- Click on the Insert Sheet button located after the last sheet.

- or Press Shift-F11 on the keyboard.

- or From the Home tab, in the Cells group, choose Insert, and choose Insert Sheet.

- or Right-click on the name of any sheet and choosing Insert... Excel will then ask what you want to insert. Choose Worksheet and click OK.

To insert multiple sheets at once, select the number of worksheets you would like to insert and follow the steps above. If three sheets are selected when you insert a worksheet, then three new sheets will be inserted. See Selecting Multiple Worksheets later in this handout.
Deleting Worksheets
You can delete a worksheet by doing one of the following:

⇒ Right-click on the name of the worksheet and choose Delete.
⇒ or From the Home tab, in the Cells group, choose Delete, and choose Delete Sheet

If the worksheet is empty it will be deleted, otherwise Excel will ask you to confirm the deletion.

![Deleting Sheets](image)

Note that the message says, "To permanently delete..." Once you confirm this deletion there is No Undo. The sheet and all the data are gone.

To delete multiple sheets at once, select the worksheets and follow the steps above. See Selecting Multiple Worksheets later in this handout.

Renaming Worksheets
You can rename a worksheet by doing one of the following:

⇒ Double-click on the name of the sheet.
⇒ or From the Home tab, in the Cells group, choose Format, and choose Rename Sheet.
⇒ or Right-click on the name of the worksheet and choosing Rename

However you choose to rename, the worksheet name will be selected.

![Renaming Sheets](image)

Type the new name and press Enter on the keyboard to accept it. Press Esc on the keyboard to cancel renaming the sheet.

Your worksheet name can contain up to 31 characters. There are a few characters that Excel won’t let use in the sheet name.

Examples: Asterisk (*), Backslash (\), Colon (:), and Brackets ([ ])

Color Coding Worksheets
You can change the color a worksheet:

⇒ Right-click on the name of the worksheet and choosing Tab Color.
⇒ or From the Home tab, in the Cells group, choose Format, and choose Tab Color.
**Moving and Copying Worksheets**

A worksheet can be moved by dragging it to a new location. Click on the worksheet name, don't let go, and drag the new worksheet left or right to the new location. When you are holding onto a worksheet, your mouse cursor will show a sheet of paper and a little black arrow will appear above the sheets, this black arrow will show you where the new worksheet will be when you let go of the mouse.

If you hold down the control (Ctrl) key while moving the worksheet, you can create a duplicate worksheet. This will copy the entire sheet, contents, formatting and all. (Remember to let go of the mouse before letting go of the keyboard.)

For more options do one of the following:

- Right-click on the sheet name and choose **Move or Copy...**
- or From the Home tab, in the Cells group, choose **Format**, and choose **Move or Copy Sheet**

The window that comes up allows you to choose a where you would like to place the sheet in the current workbook, or any open book (under the **To Book:** menu). This includes an option to create a new Excel workbook (**new book**).

Click the check box at the bottom of this window to create a copy of the worksheet.

**Hiding Worksheets**
For some templates and lookup files you may wish to hide a worksheet.

- Right-click on the name of the worksheet and choosing **Hide**.
- or From the Home tab, in the Cells group, choose **Format**, choose **Hide & Unhide**, and choose **Hide Sheet**.

**Unhiding Worksheets**
Unhide a worksheet:

- Right-click on the name of any worksheet and choosing **Unhide...**.
- or from the Home tab, in the Cells group, choose **Format**, choose **Hide & Unhide**, and choose **Unhide Sheet...**
Selecting Multiple Worksheets
The Shift and Ctrl keys on the keyboard allow you to work with multiple selections. You can use them to select multiple shapes, multiple cells, and multiple worksheets.

With multiple worksheets selected you can:
- Enter data on the current sheet and it will be entered on the selected worksheets
- Enter Formulas on the current sheet and it will be entered on the selected worksheets
- Change formats on the current sheet and it will change on the selected worksheets
- Insert multiple worksheets
- Delete selected worksheets
- Color selected worksheets
- Move selected worksheets
- Change the Page Setup for selected worksheets
- Print selected worksheets

Range of Worksheets
To select a range of worksheets use the Shift key.

1. Click on the first worksheet you would like
2. Hold down the Shift key on the keyboard and click on the last worksheet

If we click on 1st Qtr and Shift-click on 3rd Qtr, we will have all three sheets selected.

Selecting Specific Worksheets
To select specific worksheets use the control key.

1. Click on the first worksheet
2. Hold down the Ctrl key on the keyboard, and click on the second worksheet
3. Keeping the Ctrl key pressed, click on each worksheet you would like to select

If we click on 1st Qtr and Ctrl-click on 3rd Qtr, we will have only those two sheets selected.

Selecting All the worksheets
⇒ To select all the worksheets, click on the first sheet and shift-click on the last sheet.
⇒ Or right-click on any worksheet name and choose Select All Sheets.

Unselecting Worksheets
To drop the selection, click on a worksheet that is not part of the current selection. If all the worksheets are selected, click on any worksheet name except the current sheet. The current worksheet name is bold, and does not have a line above it.
Linking Cells
Linking cells is one of the operations in Excel that is so simple it's scary. When you create the Link, Excel will enter the path and keep track of the moments of the original cell.

Create a Link
Click inside the cell where we want the answer, press the **Equal** ( = ) key on the keyboard, as if we were going to build an equation, and then click on the cell we want to link to, putting Excel into a "Point" mode. From here you can click on any cell on the sheet, on another sheet, and even in another book.

Link to cell A1
Press the equal button on the keyboard. Click in cell A1. Press Enter on the keyboard.

\[=A1\]

Link to Cell A1 in Sheet2
Press the equal button on the keyboard. Click on Sheet 2, click in cell A1. Press Enter on the keyboard.

\[=\text{Sheet2!A1}\]

Link to Cell A1 in Sheet1 of Book2
Press the equal button on the keyboard. Click on Book2, Sheet1, cell A1. Press Enter on the keyboard.

\[=\text{[Book2]Sheet1!A1}\]

Using the Clipboard
Another way to create a link is to copy the original data, move to where you would like the linked value to appear and choose "Paste Link". **Paste Link** can be found on the Paste drop-down list, the right-click menu, and as an option in the Paste Special window. The icon looks like a small chain link.

Remove a Link
To break the link, delete the contents of the cell. To remove all the links, see the **Edit Link** Window section of this handout.

Absolute vs. Relative
When you link to a cell in the same workbook Excel creates a "relative" link. When the link is to another workbook it creates an "absolute" link. You can see this by the dollar signs ($) around the cell address.

You can type in or remove the dollar signs to change between the two options. **F4** is the keyboard shortcut to toggle between the absolute/relative options. This is important to our formulas and if we are going to copy or fill the cells, but the addition or lack of the $ will not change our links.

Excel will follow the address of the original data whether we are set to Relative or Absolute. However, if we are using different workbooks, Excel can only follow the data while the other book is still open. If data moves in another book, and the linked file is not open, the cell links will **not** follow.

The Absolute and Relative settings will only matter when you try to copy or fill the link. With the Absolute ($), the copy/fill will contain the same cell addresses; with the Relative (no $), the copy/fill will contain the series (i.e. A1-A2-A3...).
Linking Workbooks
As stated in the previous page linking workbooks is just as simple as linking worksheets. There is just the added step of choosing the file first. Click in the cell where you want the result to be, press the equal sign (=) on the keyboard and then use your mouse to select the workbook, click on the worksheet, click on the cell you want to link to and press Enter to accept.

The formula bar will show the full path of the linked cell. If the file is open you will see just the file name, worksheet name and cell address.

If the linked file is not open you will see the location of the file as well:

Opening Linked Files
The safest way to play with linked files is to have the original data and the linked files open when you move things around. However, that’s not always feasible.

Case 1: Open the original file and then Linked file
Result – Excel sees the links and updates all changes and will continue to update you go.

Case 2: Open Linked file by itself (or before the original)
Result – Excel prompts for permission to update links. Depending on your security settings you may see the subtle yellow security message between the ribbon and the formula bar, or the warning message box forcing you to choose.

If you ignore the message you can continue to work in Excel with the 'old' data.
If you click Enable Content Excel will update the links if it can find the original file.

If you click Don't Update you can continue to work in Excel with the 'old' data.

If you click Update Excel will update the links if it can find the original file.
Handling Broken Links
Excel does a wonderful job updating the links, *IF* it can find the file -- the sheet -- the cell you are referring to in your dataset. If the filename or sheet name has changed while the linked file is open, the links will be able to follow along, however, if they are changed while the linked file is closed Excel will lose its way.

When you ask Excel to update the link, *IF* it has a problem it will prompt you:

![Excel Link Update Prompt](image)

If you **Continue**, you can work with the "old" data.

If you click **Edit Links**... you be able to modify where the source file is located.

![Excel Edit Link Window](image)

Click on the **Change Source**... button to find the original file. *IF* the worksheet names have changed, it will then prompt to find the sheet name.

If the original files or sheets have been deleted you may need to use the **Break Link** option. This will convert all the linked cells to values. This option cannot be undone.

**Edit Link Window**
You can open the above **Edit Link** window at any time from the **Data** tab, in the **Connections** group.

![Excel Data Tab](image)
Working with Multiple Files/Windows

Ungrouping Taskbar Buttons

Your copy of Windows may try to lump all of the files into the same icon across the task bar at the bottom of the window.

But you may prefer to see them split out into individual buttons.

To do this, right-click in an empty space on the Windows Taskbar and choose Properties.

Change the option Task Bar Buttons from "Always combine" to either of the other options.

Combine when taskbar is full with lump the buttons together when the taskbar is crowded, the other will keep them separate even if there's almost no room for them.

Keep in mind this is not an Excel only feature, this is a Windows setting.

Moving Between Windows

We can use the Task Bar to move between our files, or we can use the keyboard shortcuts.

**Alt - Tab**  Moves between Applications

**Ctrl - Tab**  Moves between Open Files in Excel

*This works for Internet Browser Tabs as well*

These can be tedious if there are a lot of files open. To see a list of all the open Excel files, turn to the View tab. In the Windows group you will find a list of the open files under **Switch Windows**.

**View Different Sheets of the Same Book**

The **New Window** option on the View tab will open another window of the same Excel file. This allows you to look at two different worksheets of the same Excel file!

Use the **Arrange All** tool to fit the open windows on the screen.
Class Exercise

Review
- Open Excel
- View worksheets
  - View Options to set Default # of sheets

Rename Sheets
- Double-click on Sheet1
  - Rename to 1st Qtr
- Sheet2 -> 2nd Qtr
- Sheet3 -> 3rd Qtr

Insert a worksheet
- Click on Insert Sheet button
- Rename worksheet 4th Qtr

Label the sheets
- For each worksheet, In Cell D1 Type name of worksheet
  - Click on Sheet1, click in Cell D1, type 1st Qtr
  - Repeat for each sheet, 2nd Qtr, 3rd Qtr, 4th Qtr

Modify multiple sheets
- Click on 1st Qtr, Shift Click on 4th Qtr
- Zoom 200%
- View each worksheet

Modify specific sheets
- Click on the 1st Qtr worksheet
- Ctrl-Click on the 3rd Qtr Worksheet
  - Click in Cell D1
  - Use the Fill bucket to change the color
- Click on the 2nd Qtr worksheet
- Ctrl-Click on the 4th Qtr worksheet
  - Click in Cell D1
  - Use the Fill bucket to change the color
- View each worksheet
Enter data on multiple sheets
- Click on 1st Qtr sheet
- Right-click on the sheet name and choose Select All
  - Check title bar for [Group]
- Type:
  - A1: Big City Store
  - A2: Quarterly Sales Report
- View each worksheet
- Select All worksheets again
- Create this table:

```
<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Item</td>
<td>Price</td>
<td>Qty</td>
</tr>
<tr>
<td>1 A</td>
<td>Big City Store</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2 B</td>
<td>Quarterly Sales Report</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>A</td>
<td>123</td>
<td></td>
</tr>
<tr>
<td></td>
<td>B</td>
<td>456</td>
<td></td>
</tr>
<tr>
<td></td>
<td>C</td>
<td>789</td>
<td></td>
</tr>
</tbody>
</table>
```

Format multiple sheets
- Bold Titles and place a bottom border
- Increase Indent for Items
- Accounting ($) format Price & blank Total cells
- Center Qty
- Create formula for Total for Item A
  - =B5*C5
- Use Fill handle to create equations for Items B & C
- In cell C8: "Quarterly Total:"
  - Right Align
- In Cell D8: Use AutoSum button to total
- View Other worksheets
  - Make sure all the sheets are now unselected (no [Group] in title bar)
Adjusting formatting
- On the 1st Qtr sheet, add 987 to Item A's Qty
  - Notice Column too Narrow #######
- Select all worksheets
- Expand Column D
- Add 654 to item B’s Qty
- Turn to 2nd Qtr

Fix multiple sheets
- Click on 2nd Qtr Sheet, shift-click on 4th Qtr Sheet
- Click in cell C6 (the 654), press delete to remove unwanted data
- Click on 1st Qtr Sheet
- Confirm lack of [Group] in title bar
- In Cell C7 type 321

Create a Total’s Page
- Insert a worksheet
- Move it to Beginning
  - Drag Sheet5 to the beginning of the worksheets
- Name it Yearly Totals
- Increase the Zoom to 200%
- Type data in cells –
  - D1: Yearly Total
  - B2: 1st Qtr
    - Drag fill handle to create 2nd, 3rd & 4th Qtr labels

Link to another cell
- Link cell B6 to D1
  - In Cell B6, press equal ( = )
  - click on Cell D1
  - press Enter
- Change D1: Grand Total
  - See B6 change
Link to another sheet
- Link cell C2 to total on 1st Qtr
  - In Cell C2, press equal (=)
  - Click on sheet 1st Qtr
  - Click in D8
  - Press Enter
- View Link in formula bar
- Link Cells C3 to 2nd QTR, C4 to 3rd QTR, C5 to 4th QTR
- Calculate Grand Total in C6 Using the AutoSum
- Right Align column B

Test Links
- Turn to sheet 2nd Qtr
- Enter Qty values
  - 951, 624, 357
- View totals tab
  - Adjust Column C to fit Grand Total

Move Totals Sheet to another book
- Right-click Totals sheet
- Choose Move or Copy Sheet...
- From Book menu choose (new book)
- View Links in the Totals sheet
  - Use Ctrl~

Save Files
- Save file with the total sheet as Totals (on the desktop)
- Save file with the quarter sheets as Quarters (on the desktop)
- View Links in Totals Sheet
  - '='[Quarters.xlsx]1st Qtr'!D8
Viewing multiple files
- Switching Windows
  - Click on file names in the task list (bottom of window)
  - From the View tab, use Switch Windows
  - Press Ctrl-Tab
- From the View tab, choose Arrange All
  - Try each option
- Maximize the current window

Test Links
- In Quarters, turn to sheet 3rd Qtr
- Enter Qty values
  - 967, 688, 384
- View Totals for result

Close files
- Close Quarters
- View Links in Totals
  - ="C:\Users\prcowart\Desktop\[Quarters.xlsx]1st Qtr'!D8
- Exit Microsoft Excel

Modify Quarters file
- Open Quarters (only, don't open Totals)
- In Quarters file turn to 4th Qtr, enter values --
  - 300, 600, 900
- Close and Save

View Totals file
- Open Totals File
- See Security Warning
- Choose Enable Content (or "Update")
- Delete all totals

Set up File View
- Open Quarters File to 1st Qtr Sheet
- From the View Tab, choose Arrange All
- Tile the windows
Link across files
- In Totals, in Cell C2, press equals ( = )
- Click in Quarters file
  - The first click puts you in the book, the second in the cell
- Click in Total (cell D8)
  - Press Enter
- View Link
- Repeat to fill in 2nd Qtr, 3rd Qtr, and 4th Qtr totals
- Save both files and Exit Excel

Rename Quarters file
- On the desktop right-click on the Quarters file
- Choose Rename
- Name the file "FY 11-12"

Modify FY 11-12 file
- Open FY 11-12
- In Quarters file turn to 4th Qtr sheet
  - 975, 684, 359
- Close and Save

View Totals file
- Open Totals File
- See Security Warning
- Choose Enable Content
- Click Continue to open the file with "Old" data
- Exit Microsoft Excel

View Totals file
- Open Totals File
- See Security Warning
- Choose Enable Content
- Click Edit Links... to find the original file
- Click Change Source button
- Find FY11-12 file and click Open
- Close Edit Links window
- View new data
- Exit Microsoft Excel
View Multiple Sheets of same Book

- Open Quarters File
- Select All Sheets
- Change zoom to 100%
- Drop Group of sheets and turn to Sheet 1st Qtr
- From the View tab, choose New Window
- From the View tab, choose Arrange All, Tiled
- Change the name to "Really Big City Store"
  - Watch as it changes in the other window
- Move to 2nd Qtr Sheet
  - You are now viewing 2 worksheets of the same book
- Create two more "New Window"s
- Arrange all – Tiled
- Change each sheet to a different Qtr so you can see all four quarters at once
- Open Totals File
- Try the different Arrange options