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What is Dreamweaver? 

Dreamweaver CS3 is a powerful Hypertext Markup Language (HTML) editor used by 
professionals, as well as beginners. The program makes it easy for designers to create visually 
attractive, interactive Web pages without having to know HTML or JavaScript. However, 
Dreamweaver CS3 enables the experienced professional to write and edit HTML using the code 
editor. Dreamweaver also gives the opportunity to create web pages and learn HTML coding as 
you go along, by giving you the option of a split screen with code and design. 
 
If your department doesn’t already own a copy of Dreamweaver, you may talk to your IT 
Department about downloading a free 30 day trial from the Adobe website at 
http://www.adobe.com/products/dreamweaver/ . 
 

Before you start with Dreamweaver. 
There are a few things that need to happen before you start your web page in Dreamweaver. 
 
The very first thing you need to know is your audience.  Who is your target audience?  What 
will they be looking for in your website?  Will they be looking for entertainment, information, 
or education?  What type of equipment do they use? 
 
When you have that information, you need to plan out your website.  What information will go 
on the home page?  How many pages will your site have?  How will you navigate around the 
pages?  One of the best features about a web site is that they are not linear, but hypermedia.  
Websites are like a CD compared to an audio tape.  They can be accessed in different 
sequences depending on what each person is looking for in your website.  What images or 
other objects will you want included in the site?  A good way to lay all this out is to use sticky 
notes and lay them out to see how your site will flow, and what your layout will be.  You may 
then want to create a flow chart that will show how your pages will be linked. 
 
Next, gather all your content, such as any documents, images, movies, scripts, etc that will  
Once you have this information, you can begin to create your site by setting up the folders you 
will need for the site.  Start with the root folder (the site folder) and everything else will need 
to go in this one folder.  Even a small site must have a root folder and should also have an 
images folder and maybe even a content folder.  Larger sites may have those folders and then 
go on to add other subfolders for each section of the web site.  Each website must have its 
own root folder.  
 
Because some browsers read text case sensitive it is a good idea to have all your file names in 
lower case letters.  To make them more readable it is acceptable to use the underscore _ to 
separate words in your names.  It is best for your home page to be named index.htm.  Each 
website has a unique address or URL (Uniform Resource Locator). A browser will recognize 
index.htm as the home or opening page of your website.  It is possible to locate a home page 
with alternate names, but the URL would have to be typed out including the home page name, 
including the file extension.  In other words, to locate the home page named index.htm you 
would type in an address of http://www.website.com.  But if your home page is named 
mysite.htm, you would have to type http://www.website.com/mysite.htm.  Not a real big deal, 
but using the index file will make it more easily accessible to others.  Also Dreamweaver 
automatically recognizes index.htm and you do not have to go through an extra step to 
designate the page as your home page. 
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HTML – Hypertext Markup Language 
 
HTML is a set of codes that describe the appearance of web documents and all the objects on 
the page.  Objects could be anything from text to images to movies.  The HTML codes are 
called tags.  The tags are enclosed with the < and > symbols so the programs reading them 
recognize that they are tags.  Most items have an opening tag < > and a closing tag < />.  
For example <title> This is the title </title>.  The tags signify the beginning of an item and 
the end of that item.  Each item is called an element.  Each element can have attributes and 
the attributes can have values. Values follow an equal sign and are in quotes. HTML tags are 
not case sensitive, so it doesn’t make any difference if you use upper or lower case letters, 
however lower case is the norm.   
<ELEMENT  ATTRIBUTE= “VALUE”> or, think of it this way: 
 
<CAR  MODEL=”CAMRY”  COLOR= “RED”> 

<SANDWICH  BREAD=”WHEAT”> 

 
All HTML documents are required to have certain elements. 
 
<html>   This designates the beginning of the document. 
 
<head>    This section contains the document title, keywords, meta tags, scripts 

<title> Document title </title> 
</head>  This is the end of the Head section 
 
<body>    This designates the beginning of the Body section 
  All the content of the page would be in the body section 
</body>  This is the end of the Body section 
 
</html>  This is the end of the HTML document 
 
The World Wide Web is overseen by a not for profit group called the W3C (World Wide Web 
Consortium).  They have hundreds of members from many countries and many companies.  
They are dedicated to providing Interoperability on the web so everyone has equal access to 
the web.  From the W3C website: 

 

The World Wide Web Consortium (W3C) is an international 
 consortium where Member organizations, a full-time staff,  
and the public work together to develop Web standards.  
W3C's mission is: 
 To lead the World Wide Web to its full potential by  
 developing protocols and guidelines that ensure  
 long-term growth for the Web. 
 http://www.w3.org/Consortium/Overview 

 

One free online site that provides many tutorials with cut and paste examples is W3 Schools at 
http://www.w3schools.com/  

 
 
A few common tags are:  
<p> paragraph <br>  line break <td> table data 
<hr> Horizontal Rule (line) <H1> Heading 1 <img> image 
<a> anchor <a HREF > link &nbsp non-breaking space 
 
 

http://www.w3.org/
http://www.w3.org/Consortium/Overview
http://www.w3schools.com/


File Size, Download Time and Screen Resolution 
A couple of other items that need to be mentioned are download time and screen resolution. 
The web site you are creating is meant for viewing.  To make it as accessible as possible it is a 
good idea to limit the amount of information on each page.  Most viewers will not wait more 
than 8 seconds for a page to load.  Larger files take longer to download. If it takes too long, 
they will just go somewhere else. The pages may need to be divided up into more pages with 
less information or images on each page or the images may need to be optimized (smaller file 
size) for the web.  
 
There are various size monitors and many have different resolutions.  Resolution (for 
monitors) has to do with the number of pixels (colored squares) across and down the screen.  
Today’s monitors can be set to various resolutions. Some older monitors are set for a page 
resolution of 640 pixels wide x 480 pixels high.  Currently many monitors are set to a 
resolution of 800 x 600 or, like the monitors in the training room, 1024 x 768.   Viewers do 
not like to have to scroll side to side so some website developers limit the page size to less 
than 800 pixels, usually 760 pixels to be safe.  Before creating your web site you need to 
determine who will be viewing the site to decide the page size you want to use.  To be 
absolutely safe you may still want to create pages for the 640 pixel wide pages.  When you 
are choosing images for your web site, look at the pixel dimensions of the image.  For 
example a digital camera may take a picture that is 3000 pixels wide.  To put that image on a 
web site that image would have to be downsized quite a bit to fit on a page. Use a graphics 
program such as Photoshop or Fireworks to optimize your images.  You want to create them to 
the proper size outside of Dreamweaver and then bring them into your web site at the proper 
screen size and the smallest file size. 
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Dreamweaver CS3 Start Page 

Open existing pages 

Create new sites or pages 

Get to the Online Help Page  

 

This is the page you get when you first start up Dreamweaver CS3.  This gives you 
the option to open many different kinds of pages.  The start page can open each time 
you start Dreamweaver or it can be disabled by checking the Do not show again box. 
If you decide later you want it back go to Edit > Preferences > General and check 
the Show start page option. 
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The Dreamweaver CS3 Designer Workspace 

Dockable 
Panels 

This is the new Designer layout of the Dreamweaver CS3 where the panels are docked on the right 
side.  There is also an alternate Coder workspace that is similar to the HomeSite/Coder-Style 
workspace for those that prefer to do most of their web page creating in the HTML code view.  This 
can be changed at startup or by choosing Change Workspace in the Preferences area under the 
Edit Menu.   
The only choice in the Macintosh is the “floating” style workspace where each panel is separate. 

Menu Bar 

Insert Bar 

Document Window 
 
 This area displays the current document  
  as you create and edit it. 
  
 You can type right in this area and Dreamweaver 
  will write all the necessary code in the  
  background for you. 
 

Open documents 

Panels can be collapsed or expanded by 
clicking on the expander arrow. 

Property Inspector 

1/10/2008  9 



The Insert Bar 

 
 

Insert Bar – This is used to Insert components in your web page. 
Click icon to add images, links, forms, create layouts. All items on the 
Insert Bar can be found on the Insert Menu, but it is usually easier to use 
the buttons on the Insert Bar. 

 
 
 
 

  
Each Category offers different object to add to your page.  
Click on each tab (category) to see the different options.  
  
The Common category shown above holds the most commonly used 
choices, such as images, tables, links and media. 

 
 

 
 
 
 
 

 
This is the Layout category.  This gives options for laying out the 
web page.  In Standard mode, tables can be inserted by rows and 
columns looking like they would in a browser. Expanded mode 
temporarily adds cells spacing and padding so editing will be easier, 
but does not appear as the table would in design view. 
In Layout mode Dreamweaver CS3 allows you to draw a table and 
individual table cells for the layout of your page.  

 
 
 
 
 
 
 

 

 
Each category has a group of items each with buttons to let you add or edit objects or text.  
The Text category allows insertion of text and paragraph formatting tags. 
The Forms category includes items such as text field, radio buttons, and list menus. 
The Favorites tab can be programmed to the choices you use the most. 

The Status Bar 

 

The left side of the document Status Bar has a Tag Selector.  This allows you to select 
an item by clicking on the tag.  
The right side of the status bar gives information about the document, including the size 
of the document window and approximate download time.  Dreamweaver uses a 28.8 
modem speed as a default.  This can be changed in the Preferences area under the Edit 
menu. This area has a new zoom tool to help focus on complex design areas. 
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The Document Toolbar is where you can change your document window views   
 Code shows HTML code only (HTML) 
 Split shows both the design view and the code view 
 Design shows only the design view (similar to the way a browser sees the page) 
 

Enter your page title here.  The page title and the 
file name do not have to be the same. 

Click here to view your page 
in a true browser 

The Document Toolbar

Docked Panels 

Files Panel  
(similar to Windows Explorer) 
 
Files (such as images) can be 
dragged to the document window to 
be added to the page. 

The Property Inspector is context sensitive.  It changes for each object or text item, 
and shows the attributes for that item.  It gives an easy way to view and edit the 
properties of each item.  The expander arrow will expand or collapse the property 
inspector to show or hide properties.  Any time the property inspector is not visible, go to 
Window > Properties on the Menu bar.   
 
Another feature of Dreamweaver CS3 is the right-click context menu.  When you are 
working on an item a right-click will bring up a menu with the most useful commands and 
properties related to that particular item. 
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Starting the Web Site 
 
The first step in building a web site in Dreamweaver is to define the site.  At this point, the 
site is already planned on paper.  Now, create the folders and sub folders on the hard drive. 
You want to have something similar to folder below, where gainesville_site is the root folder 
and content and images are your subfolders.  If you have all your images and content 
gathered, it is best to put it all in the proper folders at this time.  Now we can define our site 
with Dreamweaver by specifying what the names of the folders are, and where they are 
located. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
To define your site in Dreamweaver: 
1.  Open Dreamweaver CS3. 
2.  Go to the menu and choose Site > Manage Sites. 
3.  Click New. 
4.  Choose Site. 
 When the site definition dialog box opens choose the Advanced tab. 
  (The basic tab will work, but it has more options than we need at this time.) 
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5.  Choose Local Info. 
6.  In the Site Name Text box, type the name of your website (i.e. Gainesville). 
7.  In the Local Root Folder area, click on the folder icon.  Navigate to where your root 
 folder is stored.  You should see the contents of your root folder 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
8.  Click on Select. 
9.  Make sure Refresh Local File List Automatically and Enable Cache are checked. 

(Unless you are working on a very large site, then uncheck Enable Cache) 
10. Click OK.  Click OK if the “initial cache” message pops up. 
11. Click Done. 
 

Creating the Home Page 
Begin by creating a new page 
 

1. From the menu, choose File > New. 
a. Or use the Start Up page and Choose New HTML page 

 
2.  Choose a Blank page and HTML then click Create. 
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3.  The next thing you do is save your page.  It may look like an empty page, but if you look 
at the code view, you will see there is already information about your page.  Use either 
File>Save or CTRL + S.  On the open document tab if a * is showing it means the page 
has not been saved since changes have been made.  It is always best to save your work 
continually as you go along.  Remember this will be the home page, so we want the file to be 
named index.htm.  The best practice is to name your files using all lower case letters with no 
special characters except the underscore (_) and no spaces. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
4.  In the Document Toolbar type the title of your web page.  Call this Gainesville Home 
Page or My Home Page.  Unlike filenames, the title can contain spaces and/or characters. Use 
a unique and descriptive title for your page.  This title shows on the blue title bar when you 
are viewing the page on the web. 
5.  Press Enter to apply the title to your home page. 
6.  This page will have a table in it to organize information.  Tables are set up with rows going 
across the page and columns going down the page.  Cells make up the table and have 
properties called cell spacing which is the space between each cell and cell padding which is 
the space from the cell wall to the information placed inside the cell.   
8.  Go to the Common Category of the Insert bar.  Choose the table button. 
9.  When you choose the table button the Table dialog box pops up.  Enter the number of 
rows (4) and columns (2).  
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If you do not want a Border to show, you would enter 0 in the border text box.  For this 
project we will set Cell padding (space around the content, but within the cell) to 5 and Cell 
spacing (space between the cells) to 0.  Table widths can be in pixels or in percentages (a % 
of the screen size).  You can set the table width in pixels for a fixed width table or in % for a 
flexible table.  For example a table with a 75% width will be 75% of the browser window no 
matter how the browser is resized.  If you don’t set a table width, the table will expand to fit 
the content and in a browser window will expand to fill the page.  For today’s project, set the 
Table Width to 90%.  If necessary, the table properties can be changed in the Property 
Inspector at any time.  Also the width and height can be changed by clicking and dragging 
the borders.  It is not necessary to set a height for a table.   
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Cell Spacing 

Cell Padding 

 
 
 
 

5 rows 

3 Columns 

 
 

Text 

 
 
 
 Sizing Handles 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
10.  To create the proper look for our home page, we will merge the cells in the top and 
bottom rows and the two middle rows in the 2nd column.  To merge cells, select the cells and 
click on the merge cells button on the Property Inspector (or go to the Modify Menu and 
choose Table>Merge cells).  Make sure the table is selected and choose to center it using 
the alignment buttons in the property inspector.   
 
 



Adding Content to a Page 
 
1.  In the first cell of your table, type the heading for the page.  The Delete key, the 
Backspace key and Edit>Undo all will undo actions and remove items from your page. To go 
to the next line, hit the enter key.  This will create a new paragraph which will give some 
white space above and below the text.  If you want to go to a new line, but not create a new 
paragraph, hold down the shift key and press enter.  This will create a line break but not a 
new paragraph. 
 
2.  To enter an image, go to the Common Insert Bar, and choose the image button (it looks 
like a tree).  The Image Source dialog box will open.  This will show a preview of selected 
images. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
3.  Choose your images folder.  Choose the image you want and click OK. 
Your image is now on the page where the cursor (insertion point) was located.  The Image can 
be resized.  The best practice however, is to have your picture sized properly before inserting 
it into your page by using a graphics program.  Alternatively, you can just find the image in 
your files panel and click hold and drag the image file into place.   
 
4.  Enter an alternate text for your picture.  This is a text alternative that will display if the 
picture does not load properly or if the person viewing your page does not have graphic 
capabilities, or for those “reading” the page using a screen reader.  This is one of the 
accessibility options available, and is a good practice.  Enter the text alternative in the Alt text 
box in the Property Inspector. If the image is purely decorative or if there is a text 
alternative found elsewhere on the page such as a caption, use the Alt dropdown and add a 
value of <empty> to the Alt attribute.  

 
 
 
 
 
 
 
 

5.  To direct your audience to other websites, make some hyperlinks.  Type something 
descriptive such as Go to the City of Gainesville website.  Insert a paragraph break by 
pressing the Enter key.  The enter key applies a paragraph break which gives white space 
above and below the text.  (Remember, to move to the next line without that extra space, use 
shift + Enter.) 



 
6.  Select the words “City of Gainesville”.  In the Property Inspector, in the Link text box, 
type in the full URL of the link for example    http://www.cityofgainesville.org/    and press 
the Enter key.  This will enter a hyperlink in your document and will show up underlined.  
The color of the hyperlink as well as many other options can be changed by using Cascading 
Style Sheets (CSS). 
 
7.  The link is now a working link and that is all that needs to be done.  However, in the 
Target dropdown box there are choices to make the link open in a new browser.  Choosing 
_Blank in the target drop down will make the link open in a new browser window. 
 
8.  Press Enter to make another paragraph and repeat the hyperlink process for the remaining 
links. 
 
13.  Add footer information to the page.  Items such as Created by, Copyright info and a Last 
Modified date for example.  To add the date, place your cursor in the last cell.  Then, using the 
Common Insert bar, choose the Date icon.  The date can be in many formats and if you 
check the box on the bottom it will update automatically each time the page is saved.   
 
14.  Format the headings on the page by selecting the text and using the Format drop down 
box in the Property Inspector. There are several heading options.  We format the headings 
to give the headings meaning.  Formatting a specific heading will make the content more 
meaningful to search engines and will assist screen readers. 
 
 
Save and Preview your page.  All the “content” is there, but it looks rather bland. 
 

Styles 
To make the page look better and/or more appealing, we add style to our page.  We can do 
this in different ways.  One way is to use the property inspector and add size and color to text 
on the page.  A better more efficient way to add style is to use CSS or Cascading Style Sheets.  
The CSS panel shown below is the starting point for creating styles and giving your page some 
pizzazz! 
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What are Cascading Style Sheets? 
Cascading Style Sheets (CSS) are a collection of rules we use to define and modify web pages.  
CSS are similar to styles in Word.  CSS allow Web designers to have much more control over 
their pages look and layout.  For instance, you could create a style that defines the body text 
to be Verdana, 10 point. Later on, you may easily change the body text to Times New Roman, 
12 point by just changing the rule in the CSS.  Instead of having to change the font on each 
page of your website, all you need to do is redefine the style on the style sheet, and it will 
instantly change on all of the pages that the style sheet has been applied to. With HTML 
styles, the font change would be applied to each instance of that font and have to be changed 
in each spot.   
 
CSS can control the placement of text and objects on your pages as well as the look of those 
objects.   
 
HTML information creates the objects (or gives objects meaning), but styles describe how the 
objects should appear. The HTML gives your page structure, while the CSS creates the 
“presentation”.  An external CSS is really just a text file with a .css extension.  These files can 
be created with Dreamweaver, a CSS editor, or even Notepad.   
 
The best practice is to design your web page on paper first so you know where you will want 
to use styles on your page. Then you can create the styles and apply them to your page.  

CSS Rules 
A Style Sheet is made up of Rules.  A Rule is one or more properties that will be applied to one 
or more elements.  Each rule will have a selector and a definition.  A Style Sheet can be 
collection of Styles; however, a style sheet could have just one style.   
 
A style rule consists of a selector and the properties or attributes of that selector that are to 
be affected.  These properties or attributes are contained within curly brackets and called the 
style definition.  For example in the style rule: h2 {color: red; font-family: Arial ;}, h2 is 
the selector and the rest (within the curly brackets) is the style definition. The standards of 
the style rules are that each attribute is followed by a colon (:) followed by the value for that 
attribute.  Then each set (of attribute and value) is followed by a semicolon (;).   Several style 
attributes can be assigned at one time to a tag or selector or multiple tags. For example you 
could specify the font family and color of all the heading tags at once (with a comma between 
each one) and then give each one a separate size in a different rule.  
Several tags being defined at once: 
 

h1,h2,h3,h4 { 
    color: #ff3300; 
    font-family: Arial; 
 } 
Then define the size of this one tag separately: 
 h1{ 
     font-size: 160%; 
 } 
To define a style using Dreamweaver, you can either redefine the predefined tags such as the 
Heading 1 tag, Heading 2 tag, the paragraph tag, etc. or define a custom style that you 
create.  The tag or the custom style is the selector.  One custom style is called a class.  
Classes can be used many times.  Another custom style is an ID.  An ID is similar to a class, 
but it can only be used once.  You can also create specific styles by combining selectors.  For 
example you could set up a sidebar for News and specify that only paragraph text within that 
section should be a particular color or size. 
 .news p { 
    font-size: 80%; 
    color: blue; 

} 



 CSS Styles 
 
There are three kinds of Styles: Inline, Embedded (or Internal), and External (or Linked).  One 
or more types of styles can be used for each web page. 
 
Inline styles are very similar to HTML styles in that they are placed in the <body> of your 
document and good for only that one instance.  The style definition must be marked by 
<style= attributes:values;> tags. This type is not commonly used because they are specific 
to each instance and would be time consuming to change and could not be used for other 
pages in your site. 
 
Embedded / Internal styles are placed in the <head> of your document with the tag  
<style type=”text/css”> tags.   
The selector and the definition will be enclosed by comment markers <!--  --> and end with 
</style> and will be good for the whole page.  Comment markers are good for 
documentation or to hide information from older browsers.   
 
An External (Linked) Style Sheet is a totally separate document from the HTML document and 
can be linked to and utilized by many pages.  Create the link in this manner: 
 <link rel="stylesheet"  type="text/css"        
 href="full/path/to/stylesheet.css"> 
This is telling the browser that the link relates to a CSS style sheet, it is in text and the path to 
the sheet follows the href tag.   
 
The external style sheet contains no HTML tags.  HTML tags in a style sheet can cause it to not 
function properly.  It even has its own comment tag: 
 /* CSS Comment */ 
 
Using External Style Sheets takes advantage of one of the most powerful features of CSS 
which is the ability to make changes to the style and have it immediately change all of your 
web pages.  For example if you have a particular color 
scheme that needs to be changed you would just have 
to change the properties in the style sheet and all of 
the pages linked to that sheet would be changed.  
Also if you create a style and reuse it several times 
you shrink the size of your file.  Therefore, the 
External style sheet is the type of style sheet used 
most often.   
 

Creating Styles 
The first step to create a style and style sheet is to 
open the CSS styles Panel in the Design group if it is 
not already open.  Go to the Window Menu and click 
on CSS Styles or use the Shortcut Shift + F11.  In the 
bottom right corner of the panel are four very small 
icons.  

Attach Style Sheet 

Edit Style  

Delete Style  

New CSS Style    
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To create a style, click on the New CSS 
Style icon.  The New CSS style dialog 
box will open. 

  
This text box label will change 
according to the selector type choice.  

 
 
 
 

 
 
At this point we have the option to 
define our style in a new External Style 
Sheet or if “This document only” is 
chosen it will go into the <head> of 
our document and be good for only 
that one document.  For this project 
we will be using the External Style 
Sheet, so we would choose the radio 
button for New Style Sheet File.  If you 
have already created an External Style 
sheet that file would be available as an 
option in this dialog box. If not, a 
dialog box will open for you to name 
and save your new CSS.   

 

 

 

Redefining HTML Tags 
Redefining HTML tags is one way to use 
styles. If you want to assign a background, 
a text style, or a font family to a header, 
such as h1, then you can do this by 
redefining HTML tags. Then all the h1 tags 
will change to appear as you have 
designated.  To do this, click the radio 
button that says Tag in the text box above. 
You will get a dropdown menu showing all of 
the tags that you can define styles for. 
Select the tag to redefine, click ok.  Make 
your choice to define in the current document or in a separate style sheet.  The following CSS 
Style Definition dialog box will open. This box has several categories and each category has 
several options that can be changed. 
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CSS Style Definition 

 

 

 

 

 

 

 

 

 

Type  
The first category is Type and lets us define how the text should look.  In the Font drop down 
choose a font family.  We use a family of fonts in case a particular font is not on the machine 
displaying our web page.  Make other choices as desired. Size and Weight (ie: bold) can be set 
here. 
Decoration is used frequently with the value of none to remove the underline on hyperlinks. 
Background 
The background function is used for background behind text. Take a look at the example 
shown below. This could be used as a heading/title of a paragraph. One way to do this would 
be to create a single celled table. Add a new style and choose a background color for the 
background of the cell in the table, and then choose the font and font color that you would like 
to use. If later on, you decide you want to change the background color of that cell and/or the 
font, you can edit the style.  
 

   Faculty  
 
 
Background images can be applied here.  
With CSS the image can be placed in one 
particular spot and not repeat or it can 
repeat horizontally or vertically. The 
attachment property determines if a 
background picture will be fixed (static) on 
the page or scroll with the text.    
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Block 
Select block from the list of 
categories to see options that will 
allow you to align and space the 
text.  
None in the Display dropdown box 
will turn off the display of the 
selected element. 
Block in the display category will 
create a box around the element, 
which is good for designing 
buttons. 
Box 
The box category deals with 
placement of elements on your 
page.  Float determines how other 
elements will flow around the 
element you are working with. The 
box set up is - the element 
surrounded by padding, surrounded by a border, surrounded by a margin. 

 

 Border 

 

 

Border 
You can set the border for an element.  
Each side of the border can be the same or 
different. 
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Lists 
With the lists function, you can define what a bulleted list looks like. You can choose the type 
of bullets that you would like to use, or even choose a graphic as your bullet. Or you can 
choose to have no bullets at all.  
NOTE: You will not be able to see the different types of bullets in Netscape 4.79 or 
lower. If you are using Netscape 6 or higher, it should work. 
Positioning 
Positioning can change a block of text or other element into a new layer.  Type determines 
how the browser should position the element.  Type can be absolute using coordinates from 
the top left of the page.  Relative 
places the item relative to the 
text flow.  Static places it within 
its normal location of the text 
flow.  Z-index determines the 
stacking order if there is more 
than one layer in one space.  The 
higher number layers appear 
above lower numbered layers. 

 

Extensions 
The extensions feature allows 
you to change the appearance of 
the cursor when it moves over a 
certain block of text, as long as it 
is defined by the style. As you 
may already be aware of, when 
you bring the mouse over a link 
in a browser, it becomes a hand. 
You can tell the browser to 
create a certain type of mouse icon if you bring it over normal body text. To do this, adjust the 
body text to your liking, and then go down to extensions as shown and select the cursor type 
that you would like to use.  Extensions also can create a page break or apply special filter 
effects. 

Removing the underlining from links 
In order to remove the underlining from a link, define a new style for a link by redefining the 
HTML tag. Select the link tag, ‘a’. Click ok, and now define what the text is going to look like. 
Links have an automatic style of underline, so in order to override this, you want to check 

one’ under the style decoration in the type category. You also need to select the font style 
nd other properties as you wish the links to appear.  

‘n
a

 

Applying or Removing Styles 
Styles can be applied or removed at any time. One way to apply a style to an element is to 
select the element, right click on the style in the CSS panel and choose apply.  A second way 
is to select the element, go to the style text box in the property inspector and use the pop up 
menu.  Another way to apply a style is to choose the element by clicking on the tag in the 
status bar, right click and the available classes or id’s will be listed.  Tags that are redefined 
will not appear here as those style apply automatically to the tag as it is created. To remove a 
style from an element select none in the popup menu in the property inspector or from the 
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right click on the tag in the status bar. To remove a style totally, select the style in the CSS 
Styles Panel and click on the delete button.  This will remove the style from the style sheet.  

Browser Differences 
While you are creating styles, it is important to realize that all browsers such as Netscape, 
Firefox, Opera, and Internet Explorer do not always support the same features that could be 
included in a cascading style sheet. Also each browser has its own default style sheet and 
sometimes you have to apply style rules to defeat those defaults.  For example we can set 
padding on the body tag to 0 to override Opera’s default of 12px padding on all pages.  
Dreamweaver’s debugger will point out some of the discrepancies and you can change options 
if necessary. 
 

Inserting a style sheet 
To use external style sheets, an external style sheet needs to be created, and then attached to 
each web page. When you are creating a site, you will probably define your style sheet in one 
page and then have to attach it to the rest of the pages in your site. It is important that this 
style sheet is attached to each page, or it will not function. To attach a style sheet, open up 
your page and the CSS panel in Dreamweaver. Choose the style sheet in the CSS panel and 
click on the Attach Style Sheet icon on the bottom right of the CSS panel. One style sheet can 
be used by many pages and many styles sheets can be attached to each page.   
 

Adding a new style to an existing style sheet 
To add another style to an existing style sheet, make sure that you have the “CSS Styles” 
Window open, and click the second icon, the New CSS Style icon.  
 

Copying styles 
Existing styles can be copied and then renamed and edited to create a new style. 
For example if you want the h1 tags and the h2 tags to be similar, you could create an 
h1style, duplicate it and rename it h2.  Then edit only the items that need to be different, such 
as text size.   
 

Defining your Styles using a Custom Style [.Class] 

Create a new .Class 
A Class is a set of definitions that you want 
to apply to an element.  For example you 
may want to make a heading a certain 
color, a certain size, give it a background, 
and center it on your page.  You start by 
clicking on the New CSS icon.  The dialog 
box will open.  Choose the selector type 
Class.  Name your new style. Use 
something descriptive to make it easier to 
know what they are for in the future.  Make 
sure you have a period in front of the name.  
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Advanced CSS Selectors (ID’s, Contextual Selectors, etc.) 

ID’s 
An ID is very similar to a class, but it can only be used once (applied to one item per 
document), while a class can be used many times on several items in the document. Instead 
of a period the first character of an ID is the # sign.  Then, you continue to create an ID the 
same way you would a class.  The reason for using ID’s instead of classes would be that the 
ID is used for some JavaScript functions as well as some layout options such as layers.  

Hover Effect on Links  
If you would like to create the hover effect on a link, you can do this by using cascading style 
sheets advanced selectors. To do this, click the “add a new style” icon in the SCC Styles panel.  
Instead of creating a custom style or redefining a tag, you will use the CSS Selector. Click 
Advanced in the new CSS Style dialog box. Now, you will see a dropdown menu appear that is 
titled selector. Change that to ‘a:hover,’ and then click ok. After you click ok, it will bring you 
into the same screen before that we were using to define style sheets. Select the font you 
would like to see when the mouse rolls over a link and the color if you would like to see a 
different color when the mouse rolls over the link.  
 
You can create your own selectors by combining HTML tags or combining classes or ID’s with 
tags.  For example if you want to create an unordered list within a Navbar and have that list 
without bullets you would choose The ID or class Navbar, leave a space and add the ul tag and 
that would be a new selector that you can design as you wish ie: #navbar ul. Or if you have 
a link you want to describe within an unordered list, the pair would be ul a. 

Conflicts  
Styles are applied in a cascading order, starting with the styles in the browser itself.  Then the 
styles in the External CSS are applied.  The next step is the Embedded (or Internal) Styles.  
Finally an inline style would apply.  The closest style to the element is the one that is applied if 
there is a direct conflict.  Within one style sheet, the styles at the end of the sheet would 
actually take precedence over the ones at the beginning. 

Existing Web Pages with Styles 
If you have an existing web page that was created with internal styles you can export them to 
an external CSS.  Go to the CSS Styles panel and make sure the all button is selected Click 
on the first style and use the scroll bar to go to the last style.  While holding down the shift 
key, click on the last style to choose all the styles.  Right click and choose Move CSS Rules.  
At this time you can either move them to an existing external style sheet or create a new 
external style sheet.  Once you have moved the internal rules to an external sheet, 
Dreamweaver removes them from the internal sheet and links your page to the new external 
style sheet. 

Web Polices and Resources  
 
Go to this web site for policies and resources for UF web sites. 
From this site you will also find links for images and official UF wordmarks. 
 
http://www.webadmin.ufl.edu/policies/  
 
This site will direct you to areas explaining the recommended accessibility requirements.   

http://www.webadmin.ufl.edu/policies/


Adding Styles to the page 
 
To add some background color and to set the text for the page we will add some styles to the 
body of the page 

• In the CSS panel, choose New CSS Rule 
o Define in a New Style Sheet (or choose an existing style sheet) 
o Choose Tag and enter or choose body 

 In the Type Category 
• Choose a sans serif font 
• Set the size to 100% 
• Set the color - #330099 
• Weight - bold 

 In the Background Category 
• Set the background color 
• If desired set a background image – bluebg.jpg  

o Choose the method of repeat, etc if necessary 
o Click on OK – the look of your page changes immediately because the style of 

the html tag has been changed. 
 
To change the way the Headings look 

• In the CSS panel, choose New CSS Rule.   
• Choose Tag and type or choose H1 
• Define in the same style sheet you used for the body style 
• Add the attributes you want for your H1 headings 

o In the Type Category 
 Color - #CC6633 
 Size – 38 px 
 Font - Verdana 

• Go through the same procedure for the H2 headings – change font and size 
 
When redefining html tags they affect your page as soon as you finish creating the style. 

 
To move the content away from the image on the page we will create a new Class to add 
padding to the left side of the cell. A Class is a new style that you name, create and define. 
Because this is not an existing tag, you have to apply the style for it to affect your page. 
 

• Choose New CSS Rule 
• Choose Class and name the class .padleft  (the . is required) 

o In the Box category, uncheck Padding Same for all 
o Set the left padding at 45 pixels and click OK 

• To apply the Style, with your cursor in the cell containing your content 
o Right click on the td (table cell) tag 
o Set Class to the .padleft class 

 
 

To create a footnote look, we will create a new class to make the text smaller 
• Choose New CSS rule 
• Choose Class and name it .footnote 

o In the Text category 
 Set the size to 70% 

o In the Block category 
 Text align – right 

• Select the text – right click on the selection 
o Choose CSS Styles 
o Click on the new class to apply it to the text. 
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To separate the footer information from the rest of the text we will create a new item called an 
ID.  ID’s can only be used once per page, otherwise they are similar to a class 

• Choose New CSS rule 
• Choose Advanced and name it #footer (the # is required) 

o In the Type category  
 Make the size 80% 
 Use small caps variant 
 Choose a color – White  

o In the Block category 
 Text align right 

o In the Box category 
 Uncheck padding same for all 
 Add 20 pixels of top padding 

To Make the Links look different we can alter them by creating a class called .sidebar and 
changing the way the links (html tag a) behave 

• Choose New CSS rule 
• Choose Advanced and name it .sidebar a  (this is a multiple tag) 

o In the Text category 
 Choose color – white 
 Choose text decoration – none 
 Font variant – small-caps 

• Make a second Advanced rule naming it .sidebar a:hover 
o In the Text category  

 Choose color - #333366 
o In the Background category 

 Choose background color - #FF6600 
o In the Block category 

 Choose Display – Block 
o In the Box category 

 Set width to 140 pixels 
 
Now Save All and preview the page. Big difference! 
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Creating additional pages 
When creating new pages, there are a couple of options.  You could start the same way you 
did with the first page by opening a new blank html page.  Another way is to duplicate the 
original page and delete what you don’t need and add the new content.  One way to duplicate 
the page is to open it in Dreamweaver and then use the Save As command in the File menu 
giving the page a new name. Another way is to right click the page name in the files panel, 
choose edit and then duplicate.  This way the page is linked to your style page and all your 
styles are already set up.  

• After creating the new page and giving the page a new name 
o Delete all unnecessary information 
o Merge or split cells as necessary 
o Add content – Format as necessary (ie. H1) 
o Add images 
o Give the page a new title and save 

 
The last page in the site will be a map page with a rollover image. A rollover image is two 
images located in the same space. One image is the base image. Then, when the mouse is 
over the image the second image shows. Move the mouse and the first image takes its place 
again. 
 
1. Using your first page, create a new HTML page. Save the page. Give it a title (In the 
Document toolbar). This will be our Map page. Type and format the Heading (Gainesville 
Driving Directions) on the page.  
2. Click to place your cursor in the proper table cell.  In the Common Insert bar, click on the 
small triangle next to the image button. In the drop down box, choose Rollover Image. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

3. Use the browse buttons to locate the images. Select the images to go on the page. The 
standard non-rollover picture is the Original image. Also check Preload Rollover Image to 
make the image cache in the browser so the picture will load quickly. As with all images, type 
in an alternate text.  Click OK. Save the page and preview in the browser. Test the rollover 
image to make sure the pictures swap out as the mouse rolls over the image.  
 
4. Add the directions text in the proper cell.   
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Adding a Navigation Bar 
 
Once you have a group of web pages you want to make sure that anyone looking at the pages 
can maneuver through your site at will.  We will use a table to add a navigation bar. 
 
1.  Open your Home page.  Insert a table with 1 row and the # of columns to match the 
number of pages in your site.  Use 0 for border, cell spacing and cell padding.  Set the 
width at 90%. Click OK. 
2.  The table is on the page and selected.  While it is still selected, use the Property 
Inspector to align the table on the page by choosing Center from the Align drop down 
box.  If the table is not selected, it can be selected easily by clicking on the tag in the Tag 
Selector on the Status bar.   
3.  Click in the first cell and drag your cursor through the cells to select the whole row.  Click 
on the Align Center button on the Property Inspector to align the contents of all the cells 
to the center. 
4.  Type a name for each page in each cell.   
5.  Select the name in the first cell. Using the Point to File button in the property inspector 
next to the Link text box, click hold and drag to the proper file in the file panel.  The Point 
to file button will automatically fill in the Link box for any file in your file panel. 
6.  Repeat the process for each page. 
7.  Save the page and preview it in the browser.  Make sure all the links work properly. Now 
we need a way to get back to the home page and move around the other pages. 
8.  On the Home page select the Navigation table by clicking in the table and then selecting 
the table tag in the tag selector in the status bar at the bottom of the page.  Copy the 
table (Edit> Copy or CTRL+C).  Open your other pages and paste the table there 
 
 
Another option is to use Dreamweaver’s 
Navigation Bar.  This requires four images for 
each link that are exactly the same size.  You 
need an image for Up, Over, Down, and 
OverDown.  Once you have all four images 
prepared for each link, go to the Image insert 
button and choose Navigation Bar. 
Give the link an Element Name and then 
browse for each image.  Add the URL for the 
link and make sure Preload Images is selected.  
You may want to select Show “Down Image” 
initially for the page you are currently working 
on. Decide if you want the bar to be vertical or 
horizontal and whether you need it to be in 
tables.  Once the first link is finished, click on 
the plus to add additional links. When finished, 
click OK and you will have a new Navigation 
Bar on your page. 
 
When your bar is finished, you can select the Navigation Bar and paste it on each of your 
other pages.  Then from the Modify menu item, choose Navigation Bar and then you can 
change the initial state of the button for each current page.  
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Test the Site  
 
Before you put your site on a server it is best to test it on your local machine.  
1.  Open your Browser (Internet Explorer, Netscape, Mozilla, etc.) 
2.  From the browser Menu bar choose File > Open.  Locate your root folder and choose 

your home page (index.htm).  Your site should open in the browser. 
3.  Test all the links, both the links to your pages as well as the external links to other sites. 

Test to make sure the email links works.  (Don’t send email; just make sure it brings 
up the email client.) Remember to get back to your site from other sites you may have 
to use the browser’s Back button. 

Post the website to a server 
 
There are a few ways to get the website “live” and viewable by the public.  
 
Many departments have a public folder that will allow you to copy your website in the folder 
and get a URL so anyone can navigate to the website with a browser.   
 
Another way to post the site is to use FTP.  That is a File Transfer Protocol.  FTP is a process 
where the files are uploaded to a server and are then available for viewing. 
 
Check with your department IT person as to how this would be done in your department. 
 
Once you have a folder on the “live server” you can go to Site > Manage Sites to edit the 
remote site information.  Then use the big blue Put arrow in the files panel to upload your 
files. 
 
Many email servers allow a certain amount of space for personal websites. 

Helpful Keyboard Shortcuts 
 

 
 
 
 
 
 
 
 

Command Shortcut 
Save CTRL + S 
Copy CTRL + C 
Cut CTRL + X 
Paste CTRL + V 
Clear Delete / Backspace 
 
Another shortcut is to use the mouse right click.  When you are working with an item on the 
page, if you right click on the item you will get a context menu.  This has many commonly 
used options for that particular item.  
 
You can create your own keyboard shortcuts.   

• From the edit menu choose Keyboard shortcuts.  Make a copy of the standard 
shortcuts (this way if you don’t like the new shortcuts you can always get back to the 
original set. 

• Give the copy a new name 
• Choose a command you would like to create a new shortcut for, for example Save All  
• Choose the keys you want to use. 

o If the key combination is already in use as a shortcut it will tell you and you 
can choose something else. 

• When you are happy with your shortcuts click Change and then OK 
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