Microsoft Access 2010
Forms & Macros
Microsoft Access 2010: Forms & Macros

1.5 hours

This workshop requires completion of "Access: Basics", "Intro to Forms and Reports", and "Forms". Topics include creating menus; linking forms through buttons; creating tabular SubForms; creating macros; using macros in buttons and in other events.

Main Menu – Review .................................................................................................................................................. 1
Start up Options .................................................................................................................................................. 1
Modifying Form Properties ........................................................................................................................................ 2
Linking Forms - Review ........................................................................................................................................ 3
Tabular Form ........................................................................................................................................................ 4
Inserting a SubForm ................................................................................................................................................ 5
  Modifying a SubForm ........................................................................................................................................... 6
Creating a Macro .................................................................................................................................................. 7
  Open Form Action Arguments ............................................................................................................................ 8
  GoToRecord Form Action Arguments ................................................................................................................ 8
  Note for Earlier Versions ..................................................................................................................................... 8
Creating a Button to Run a Macro ....................................................................................................................... 9
  Using the Command Button Wizard ................................................................................................................ 9
  Using the Property Sheet .................................................................................................................................... 9
  Dragging from the Navigation Pane ................................................................................................................ 9
Modifying Existing Buttons ............................................................................................................................... 10
Macro Actions ................................................................................................................................................... 11
Non-Button Macros ............................................................................................................................................ 12
Help ................................................................................................................................................................. 12

Pandora Rose Cowart
Senior Training Specialist
Academic Health Center Training

C3-012A Communicore
PO Box 100152
Gainesville, FL 32610-0152
(352) 273-5051
prcowart@ufl.edu
http://training.health.ufl.edu

Updated 11/28/2011
Main Menu – Review
Recreate the Main Menu form and set it to open when the database starts. It does not need to look just like this one, but it should have five working buttons.

1. From the Create tab, click on the Form Design button

2. Create Command Buttons by using the controls on the Design tab
   a. Be sure to give the buttons unique names
   b. Each Open Form button should return ALL the records
   c. Application category -> Quit Application

3. Save Form as "Main Menu"

4. Test each of the buttons to make sure they are opening the forms you wanted

5. (If you have time) Format as desired
   a. Use the Quick Styles and Change Shape options on the Format tab
   b. Use a Label to create the title

Start up Options
1. Open the File menu, Choose Options near the bottom of the menu

2. Choose Current Database from the pane on the left

3. In the Application Options – Change the Display Form to Main Menu
Modifying Form Properties

1. In the design view open the Form properties

2. Turn off extra views
   a. *(allow form view YES)*
   b. Allow Datasheet View No
   c. Allow PivotTable View No
   d. Allow PivotChart View No
   e. Allow Layout View No
   f. Allow Datasheet View No

3. Turn off Record buttons
   a. Records Selectors No
   b. Navigation Buttons No

*Note:* Remember you can Double-click on the drop down lists in the properties and it will cycle to the next value on the list. In these cases: Yes becomes No.
Linking Forms - Review

The Employees form has a button on the department tab that opens the department for just that employee. We'll do the same for the Patient's form; create a button to open the Visits for just this Patient.

1. Open the Patients form
2. Create Command Button by using the control on the Design tab
   a. Form Operation -> Open Form -> Patient Visits
   b. "Open the form and find specific data to display"
   c. Choose Med Rec from each side to help Access see the link between the two forms
   d. Set the button to show a picture and give it a meaningful name
3. Test the button
4. Adjust Placement and Reformat
**Tabular Form**

The Employee table is currently embedded in the Department form. We want to make a Tabular SubForm to replace it.

1. Select the Employee table from the Navigation Pane

2. From the Create Tab, under the More Forms menu, Choose Multiple Items

3. Turn to the design view

4. Delete all the fields but **First** and **Last**

5. Delete the Employees title and Forms image

6. Size labels and text boxes to the "shortest"
   a. Move labels to the top of their section

7. Resize the header and detail sections

8. Open Form Properties (data tab)
   a. Allow Deletions *No*

9. Add a button to open the employee form for this employee
   a. From the Design Tab, create a Command button
   b. Open A Form, Employee Form, Find specific data to display
   c. Link by Last
   d. Caption "More Info"
   e. Give it a meaningful name

10. Test the button

11. Move the button to the Header
    a. Test again

12. Move back to the detail

13. Select All, from the Arrange Tab choose **Tabular**
    a. Adjust size of Name fields in Layout View

14. Close and Save as "Departments SubForm"
**Inserting a SubForm**

1. Open the Departments Form in Design view

2. Delete Employees table

3. Open the Controls menu on the Design tab click on the SubForm button
   a. Click in the grid to place it on the form

4. Follow the steps of the wizard
   a. Use an Existing Form – **Departments SubForm**

   ![SubForm Wizard](image)

   b. Because our relationships are set up properly and we aren't doing anything fancy, Access knows to link these by Dept ID, but we can click on the **Define my own option** to set it ourselves

   ![Choose from a list](image)

   c. Name the control Department Employees

   The size of the control is determined by the size of the grid of the SubForm. Let's go fix it and try again.

   1. Close and don't save the Departments form

   2. Open the Departments SubForm Form in design view

   3. Adjust the grid to be under 4" wide

   4. Close and Save Department's SubForm

   5. Repeat steps at the top of this page to reinsert the SubForm Control into the Departments Form
Modifying a SubForm

1. Once the SubForm is in place, go to the Layout View

2. Resize the SubForm to fit at least 6 employees

3. Go to the Design View

4. Open the Property Sheet

5. Click once on the SubForm control to select it

6. Click on it again to 'get inside'
   a. Look for the mark in the top left corner that shows which form is currently selected

7. In the Form properties of the SubForm change -
   a. Allow Additions No
   b. Navigation Buttons No

8. Turn to the Form View, make sure you turned off the correct properties
**Creating a Macro**

Buttons are limited to only one action at a time: open a form; go to the next record, exit the application. If you want a button to do multiple tasks you can set up a Macro and then have the button do the single 'miscellaneous' task of: **Run a Macro**.

![Macro Button Wizard](image)

We are going to create a New Patient button and a New Employee button for our Main Menu. To create a new record we need to (1) Open a form and (2) Go to a new Record. We can create buttons to do each, but not both.

1. From the Create Tab, choose Macro
2. From the Action menu choose **Open Form**
3. Change the **Form Name** property to be **Patients**
   a. Leave the other properties alone
4. For the next step, choose **GoToRecord** from the Action menu
5. Change the **Record** property to be **New**
   a. Leave the other properties alone
6. Save the Macro as "New Patient"
7. Run the Macro
   a. It should take you to a blank Patient form to Record 77
Open Form Action Arguments
Form Name – This drop down list will provide you with a list of all the forms in your database.

View – Form, Design, Print Preview, Datasheet, ...

Filter Name – Name of a Query (spelling counts) that will limit your records

Where Condition – An SQL statement such as Select * from Patients where Patient.City="Waldo"

Data Mode – Add, Edit, or Read Only. If you leave this blank, Access will open the form as it's saved.
   Add – Data Entry property set to Yes. This will open the form and ONLY show you a new record.
   Edit – Properties Allow Additions, Allow Deletions, Allow Edits all set to Yes.
   Read Only – Properties Allow Additions, Allow Deletions, Allow Edits all set to No.

Window Mode – Normal, Hidden, Icon, Dialog.
   Normal – Opens the way the database is set (Overlapping Windows or Tabbed Documents)
   Hidden – Opens the form but hides it from view. This is a simple way to make a global variable.
   Icon – When you are using the Overlapping Windows this will minimize the form
   Dialog – Properties Modal, and Pop up are set to Yes. This will open the form as a floating window
   This is good for search boxes, error messages, and search windows.

GoToRecord Form Action Arguments
Object Type – Table, Query, Form...

Object Name – This list will populate with options based on the selection in the Object Type. If Object Type and Object Name are left blank, Access assumes the 'current' database object.

Record – Previous, Next, First, Last, GoTo, New

Offset – This option is used when the Record choice is "GoTo". We go to an offset of... i.e. +5 will jump forward 5 records, -5 will jump back. This is especially useful when we have data with many similar values. Instead of moving one record at a time we can 'Jump' via our Offset.

Note for Earlier Versions
If you are using Office 2007 or earlier, your macro screen, it will look more like this one.

Instead of having the Action Arguments under each Action, they appear at the bottom of the window.

The Action list and Action Arguments are the same, but in this new Office 2010 version it looks very different.
Creating a Button to Run a Macro

**Using the Command Button Wizard**

1. Open the Main Menu form in Design View
2. From the controls in the Design tab, create a Command Button
3. Choose the **Miscellaneous** category, **Run Macro** action
4. Choose the New Patient Macro
5. Change the text to **New Patient**
6. Give the button a meaningful name
   a. Something like, cmdMcrNewPatient
7. Test the Button
8. Format the button to look like the others

**Using the Property Sheet**

1. Copy and Paste the button, Change the Caption (name) to be **New Employee**
   a. Align it with the Employee button
2. Create a New Employee Macro
3. New Employee Button still opens Patients Form
4. Open the Property Sheet for the New Employee button
   a. Change the **On Click** property (event tab) to **New Employee**
5. Open the Property Sheet for the New Patient button
   a. Change the **On Click** property to **New Patient**

**Dragging from the Navigation Pane**

1. Open the Patients Form in Design View
2. Drag the New Patient macro onto the form
3. Adjust format and placement
4. Open the Patient Visits Form in Design View
5. Drag the New Patient macro onto the form
6. Adjust Format and Placement
Modifying Existing Buttons
In Access 2003 or earlier buttons were based on VBA, Visual Basic for Applications code. If we needed to edit a button we had to wade through screens such as this:

```
Option Compare Database
Private Sub cmdExitDatabase_Click()
On Error GoTo Err_cmdExitDatabase_Click

If Me.Dirty Then Me.Dirty = False
DoCmd.Quit

Exit_cmdExitDatabase_Click:
Exit Sub

Err_cmdExitDatabase_Click:
MsgBox Err.Description
Resume Exit_cmdExitDatabase_Click
End Sub
```

Beginning in Office 2007, new buttons are created with Embedded Macros. So instead of a "Event Procedure", our **On Click** properties give us "Embedded Macro".

We're going to change the **More Info** button on our Departments SubForm to show us the employee's picture.

1. Open the Departments SubForm in design view

2. Open the properties for the More Info button

3. Change the look of the button
   a. Format Tab – click in the **Picture** property
   b. Click on the ... at the end of the line
   c. Find the **Happy Face** and click OK

4. Change the event
   a. Event Tab – click in the **On Click** property
   b. Click on the ... at the end of the line
   c. Add a New Action
      i. **GoToControl**
      ii. **Control Name**
         Picture
   d. Close and Save

5. Test the button
**Macro Actions**

Here is a list of all the Macro actions. If you don't see them on your list, be sure to turn on the **Show All Actions** button in the Show/Hide group on the Macro Tools Design Tab.

<table>
<thead>
<tr>
<th>Comment</th>
<th>AddContactFromOutlook</th>
<th>AddMenu</th>
<th>ApplyFilter</th>
</tr>
</thead>
<tbody>
<tr>
<td>Group</td>
<td>LockNavigationPane</td>
<td>MaximizeWindow</td>
<td>MessageBox</td>
</tr>
<tr>
<td>If</td>
<td>MinimizeWindow</td>
<td>MoveAndSizeWindow</td>
<td>NavigateTo</td>
</tr>
<tr>
<td>SubMacro</td>
<td></td>
<td></td>
<td>SaveObject</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>SaveRecord</td>
</tr>
<tr>
<td>Beep</td>
<td></td>
<td></td>
<td>SearchForRecord</td>
</tr>
<tr>
<td>BrowseTo</td>
<td></td>
<td></td>
<td>SelectObject</td>
</tr>
<tr>
<td>CancelEvent</td>
<td></td>
<td></td>
<td>SendKeys</td>
</tr>
<tr>
<td>ClearMacroError</td>
<td></td>
<td></td>
<td>SetDisplayedCategories</td>
</tr>
<tr>
<td>CloseDatabase</td>
<td></td>
<td></td>
<td>SetFilter</td>
</tr>
<tr>
<td>CloseWindow</td>
<td></td>
<td></td>
<td>SetLocalVar</td>
</tr>
<tr>
<td>CollectDataViaEmail</td>
<td></td>
<td></td>
<td>SetMenuItem</td>
</tr>
<tr>
<td>CopyObject</td>
<td></td>
<td></td>
<td>SetOrderBy</td>
</tr>
<tr>
<td>DeleteObject</td>
<td></td>
<td></td>
<td>SetProperty</td>
</tr>
<tr>
<td>DeleteRecord</td>
<td></td>
<td></td>
<td>SetTempVar</td>
</tr>
<tr>
<td>DisplayHourGlassPointer</td>
<td></td>
<td></td>
<td>SetValue</td>
</tr>
<tr>
<td>Echo</td>
<td></td>
<td></td>
<td>SetWarnings</td>
</tr>
<tr>
<td>EditListItems</td>
<td></td>
<td></td>
<td>ShowAllRecord's</td>
</tr>
<tr>
<td>EmailDatabaseObject</td>
<td></td>
<td></td>
<td>ShowToolbar</td>
</tr>
<tr>
<td>ExportWithFormatting</td>
<td></td>
<td></td>
<td>SingleStep</td>
</tr>
<tr>
<td>FindNextRecord</td>
<td></td>
<td></td>
<td>StartNewWorkflow</td>
</tr>
<tr>
<td>FindRecord</td>
<td></td>
<td></td>
<td>StopAllMacros</td>
</tr>
<tr>
<td>GoToControl</td>
<td></td>
<td></td>
<td>StopMacro</td>
</tr>
<tr>
<td>GoToPage</td>
<td></td>
<td></td>
<td>UndoRecord</td>
</tr>
<tr>
<td>GoToRecord</td>
<td></td>
<td></td>
<td>WordMailMerge</td>
</tr>
<tr>
<td>ImportExportData</td>
<td></td>
<td></td>
<td>WorkflowTasks</td>
</tr>
<tr>
<td>ImportExportSpreadsheet</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ImportExportText</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Comment</td>
<td></td>
<td></td>
<td>RunMacro</td>
</tr>
<tr>
<td>Group</td>
<td></td>
<td></td>
<td>RunMenuCommand</td>
</tr>
<tr>
<td>If</td>
<td></td>
<td></td>
<td>RunSavedImportExport</td>
</tr>
<tr>
<td>SubMacro</td>
<td></td>
<td></td>
<td>RunSql</td>
</tr>
<tr>
<td>AddContactFromOutlook</td>
<td></td>
<td></td>
<td>SaveAsOutlookContact</td>
</tr>
<tr>
<td>AddMenu</td>
<td></td>
<td></td>
<td>SaveObject</td>
</tr>
<tr>
<td>ApplyFilter</td>
<td></td>
<td></td>
<td>SaveRecord</td>
</tr>
<tr>
<td>Beep</td>
<td></td>
<td></td>
<td>SearchForRecord</td>
</tr>
<tr>
<td>BrowseTo</td>
<td></td>
<td></td>
<td>SelectObject</td>
</tr>
<tr>
<td>CancelEvent</td>
<td></td>
<td></td>
<td>SendKeys</td>
</tr>
<tr>
<td>ClearMacroError</td>
<td></td>
<td></td>
<td>SetDisplayedCategories</td>
</tr>
<tr>
<td>CloseDatabase</td>
<td></td>
<td></td>
<td>SetFilter</td>
</tr>
<tr>
<td>CloseWindow</td>
<td></td>
<td></td>
<td>SetLocalVar</td>
</tr>
<tr>
<td>CollectDataViaEmail</td>
<td></td>
<td></td>
<td>SetMenuItem</td>
</tr>
<tr>
<td>CopyObject</td>
<td></td>
<td></td>
<td>SetOrderBy</td>
</tr>
<tr>
<td>DeleteObject</td>
<td></td>
<td></td>
<td>SetProperty</td>
</tr>
<tr>
<td>DeleteRecord</td>
<td></td>
<td></td>
<td>SetTempVar</td>
</tr>
<tr>
<td>DisplayHourGlassPointer</td>
<td></td>
<td></td>
<td>SetValue</td>
</tr>
<tr>
<td>Echo</td>
<td></td>
<td></td>
<td>SetWarnings</td>
</tr>
<tr>
<td>EditListItems</td>
<td></td>
<td></td>
<td>ShowAllRecord's</td>
</tr>
<tr>
<td>EmailDatabaseObject</td>
<td></td>
<td></td>
<td>ShowToolbar</td>
</tr>
<tr>
<td>ExportWithFormatting</td>
<td></td>
<td></td>
<td>SingleStep</td>
</tr>
<tr>
<td>FindNextRecord</td>
<td></td>
<td></td>
<td>StartNewWorkflow</td>
</tr>
<tr>
<td>FindRecord</td>
<td></td>
<td></td>
<td>StopAllMacros</td>
</tr>
<tr>
<td>GoToControl</td>
<td></td>
<td></td>
<td>StopMacro</td>
</tr>
<tr>
<td>GoToPage</td>
<td></td>
<td></td>
<td>UndoRecord</td>
</tr>
<tr>
<td>GoToRecord</td>
<td></td>
<td></td>
<td>WordMailMerge</td>
</tr>
<tr>
<td>ImportExportData</td>
<td></td>
<td></td>
<td>WorkflowTasks</td>
</tr>
<tr>
<td>ImportExportSpreadsheet</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ImportExportText</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Non-Button Macros

While we use buttons to activate macros it is possible to have them run automatically, in the background. Button's run a macro or event procedure on the event that they are 'clicked'. But there are lots of other events that can trigger a macro or event procedure.

We're going to create a button that will run when a form is closed. Each time we close a Form we would like the Main Menu to open. Let's create a simple macro that opens the Main Menu.

1. From the Create Tab, choose Macro
2. From the Action List, choose Open Form
3. From the Form Name, choose Main Menu
4. Close and save as "Return to Main"

We could create a macro that would close the form and then open the main menu, but what if they use the X in the corner, or the keyboard shortcuts (Ctrl-W, Ctrl-F4)? No matter how the form is closed, we would like the Main Menu to open. We're going to assign this macro to run anytime a form is closed.

1. Open the Patient's Form in Design View
2. Open the Property Sheet for the Form
3. Turn to the Event Tab
4. Set property On Close to be Return to Main
5. Repeat for each of the other main forms
   a. Patient Visits, Departments, and Employees
   b. In Design view set property On Close to be Return to Main

Help

Some of the Event names are not clear. This is true of many of the property options. Watch your status bar as you click inside each property option, you'll see a small description that may help.

Beyond that there is help through the Access Help button , online through the Microsoft Support , a myriad of online forums, and of course me. I'm happy to help the best I can.

And please, try to avoid the VBA Code if you can.